I am new to Compiere and just downloaded the professional edition for evaluation.  I installed the system with the predefined database and tenant GardenWorld.  Then I tried to play around with the Requisition workflow.  Here is what i've done based on Swing UI:

1. login as GardenUser and added a Requisition.  Meaning of some of the fields is unknown to me so I just put in something at random.  In the Requisition's header I used: (i) Employee =GardenUser (ii) Document Type=Purchase Requisition (iii) Tenant=GardenWorld (iv) Organization=HQ (v)Warehouse=HQ Warehouse.

2. I then added 1 Requisition Line to the above header: (i) Line No=10 (ii) Product=Plum Tree (iii) Quantity=13 (iv) Line Amount(auto calculated by system)=617.5 (i assume this amount would cause the system to require approval)

3. I then login as GardenAdmin, and the Workflow Activities Tab after the login showed 1 activity to be approved (which was the Requisition I just made in the 2 steps above).  I then proceeded to approve it by selecting Yes and clicking the Tick button.  The system then continued its processing.

And the problem I encountered:

1. While login as GardenAdmin,  I reviewed the approved Requisition record but found that the Document Status unexpectedly became "Not Approved" although I just approved it. 

2. I then clicked the Active Workflow button to check out why and found these:

(i) In Process tab, Workflow=Process_Requisition, Workflow State=Aborted
(ii) In Activity tab, Text Message contains these "IsApproved=Y, - Cannot Approve - No Approver"

So now I assume the cause of "Not Approved" is the "Cannot Approve - No Approver".  So what is the meaning of this message?  I've changed the steps by, say, using GardenAdmin to enter the record and using GardenAdmin to self-approve the record but exactly the same error appeared.  Anyone know what caused this problem?

I am not quite familiar with the requisition workflow and security role concepts.  Would that be something I missed in these 2 areas?