Deploying Webservice in Compiere

2009-06-10
2013-05-02
  • Parag Patil
    Parag Patil
    2009-06-10

    Hi friends,
    I am trying to deploy webservice in Compiere JBOSS but it gives following error message
    [java] Processing file D:\CompiereInstall\CompiereWebService\build\wsdd/com/compiere_service/deploy.wsdd
    [java] Exception: AxisFault
    [java]  faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
    [java]  faultSubcode:
    [java]  faultString: java.net.ConnectException: Connection refused: connect
    [java]  faultActor:
    [java]  faultNode:
    [java]  faultDetail:
    [java]     {http://xml.apache.org/axis/}stackTrace:java.net.ConnectException: Connection refused: connect
    [java]     at java.net.PlainSocketImpl.socketConnect(Native Method)
    [java]     at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
    [java]     at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
    [java]     at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
    [java]     at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
    [java]     at java.net.Socket.connect(Socket.java:519)
    [java]     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    [java]     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    [java]     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    [java]     at java.lang.reflect.Method.invoke(Method.java:597)
    [java]     at org.apache.axis.components.net.DefaultSocketFactory.create(DefaultSocketFactory.java:153)
    [java]     at org.apache.axis.components.net.DefaultSocketFactory.create(DefaultSocketFactory.java:120)
    [java]     at org.apache.axis.transport.http.HTTPSender.getSocket(HTTPSender.java:191)
    [java]     at org.apache.axis.transport.http.HTTPSender.writeToSocket(HTTPSender.java:404)
    [java]     at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:138)
    [java]     at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
    [java]     at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
    [java]     at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
    [java]     at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165)
    [java]     at org.apache.axis.client.Call.invokeEngine(Call.java:2784)
    [java]     at org.apache.axis.client.Call.invoke(Call.java:2767)
    [java]     at org.apache.axis.client.Call.invoke(Call.java:1792)
    [java]     at org.apache.axis.client.AdminClient.process(AdminClient.java:439)
    [java]     at org.apache.axis.client.AdminClient.process(AdminClient.java:404)
    [java]     at org.apache.axis.client.AdminClient.process(AdminClient.java:410)
    [java]     at org.apache.axis.client.AdminClient.process(AdminClient.java:320)
    [java]     at org.apache.axis.client.AdminClient.main(AdminClient.java:463)
    [java]
    [java]     {http://xml.apache.org/axis/}hostname:nuca177
    [java]
    [java] Java Result: 1

    Does anybody know, why this error message is popping up?
    Does anybody tried to deploy Web services in the Compiere JBOSS?

    Thanks and Regards
    Parag Patil.

     
    • Parag Patil
      Parag Patil
      2009-06-10

      I tried to deploy the same service on normal JBOSS server and it did get deployed successfully?