compiere and ireport with charts

yomisma2
2010-06-14
2013-05-02
  • yomisma2
    yomisma2
    2010-06-14

    Hi,

    I have jasperreport correctly integrate in compiere. Reports works fine. But now, I want to run a report that has a chart (works fine in ireport). But I get the next error:
    ReportStarter.processReport: Can not load report - Error loading object from file : C:\SC\install\build\Compiere2\reports\MiReportGrafica.jasper

    What's happening?? I don't know how to fix it.

    Please, help!!

     
  • yomisma2
    yomisma2
    2010-06-18

    I have changed the libraries and I've copied the jasperreports-3.0.0.jar, commons-beanutils-1.7.jar, commons-collections-2.1.jar, commons-logging1.0.2.jar, poi-3.0.1.FINAL-20070705.jar, jfreeChart-1.0.3.ar From ireport/lib and I've pasted them in tools/lib.

    If i try running a report without reports works fine (in ireport and in compiere), but if I add a chart it doesn't work. It works in ireport but not in compiere. Compiere is procesing and procesing and I don't get no error and no report.

    How can I fix it??

    Please, help!!

     
  • yomisma2
    yomisma2
    2010-06-18

    Sorry but I realize that I made a mistake writting before, so here is the good one.

    I have changed the libraries and I've copied the jasperreports-3.0.0.jar, commons-beanutils-1.7.jar, commons-collections-2.1.jar, commons-logging1.0.2.jar, poi-3.0.1.FINAL-20070705.jar, jfreeChart-1.0.3.ar From ireport/lib and I've pasted them in tools/lib. If i try running a report without CHARTS  works fine (in ireport and in compiere), but if I add a chart it doesn't work. It works in ireport but not in compiere. Compiere is procesing and procesing and I don't get no error and no report. How can I fix it?? Please, help!!