compat32pkg / News: Recent posts

compat32pkg 1.6.130502 released !

Hello,

A new version of compat32pkg is available. This version includes the latest revision of the layer-32 descriptor, and comes with the new command "--depends" which allows to list the dependency required by a 32-bit binary, or by the 32-bit binaries in a directory hierarchy, or by the 32-bit binaries from an installed package.

Have fun !

--
SeB

Posted by Sébastien Ballet 2013-05-03

Maintenance release

A maintenance release (1.5.120822 build 6) is available. This (only) includes latest revision of 32-bit layer descriptor, which has been updated following the changes made by Eric to the multilib.

Posted by Sébastien Ballet 2012-11-20

New release

compat32pkg 1.4.120430 is out.

Posted by Sébastien Ballet 2012-05-02

revision 1.3.110319 build 4

Hello,

This one comes with latest changes made to the configuration file for the layer-32, and corrects a small bug (related to display only) into the update mechanism for this same file.

--
SeB

Posted by Sébastien Ballet 2011-03-28

compat32pkg 1.3.110319 is out !

Hello,

This revision corrects a design flaw, provides a new feature, and includes the latest changes made by Eric Hameleers to the configuration file for the "layer-32" (ie the 32-bit part of the multilib).

You will find more details about all of this here:
http://www.linuxquestions.org/questions/slackware-14/%5Bann%5D-compat32pkg-1-3-110319-is-out-869831/
Users of earlier version are encouraged to update to this revision.... read more

Posted by Sébastien Ballet 2011-03-20

A new release is available (1.2.110112)

Hello,

This new version corrects a small, but annoying, bug introduced
by previous version (ie 1.1.110107).

Users of earlier versions, and especially of version 1.1.110107 are
encouraged to upgrade to version 1.2.110112.

Cheers.

--
SeB

Posted by Sébastien Ballet 2011-01-14

A maintenance release of compat32pkg is avail

This maintenance release includes some little improvements, and updates the list of packages that provide the 32-bit part of the multilib (ie 32-bit compatibility layer).

Users of earlier versions are encouraged to upgrade to this release.

Greetings.

--
SeB

Posted by Sébastien Ballet 2011-01-09

A new version of compat32pkg is available

Hello,

This new version provides some corrections and introduces a tiny improvement related to the management of 32-bit part of the multilib.

Indeed, since then, to install the "32-bit layer using compat32pkg" the users had to pass the file /etc/compat32pkg/multilib-32bit-packages.lst.

The new version "1.0.101201" simplifies this by introducing the keyword "layer-32" which is an alias for the file /etc/compat32pkg/multilib-32bit-packages.lst that can be passed in argument of --convert, --install, --check-updates, --list-updates, --convert-updates, --upgrade, remove, and, --exclude.... read more

Posted by Sébastien Ballet 2010-12-01