Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Does comoblog run on PHP5 on apache2 /Linux??

Help
hans
2006-10-15
2013-04-02
  • hans
    hans
    2006-10-15

    now its really time up upgrade to comoblog 1.1 from my well running easymoblog 0.51 ...

    I move to a new dedicated server ( my ISP warned me for too much traffic ... )

    and I move from early php4 to new php5 now and got like apparently many ten thousands
    ( see google
    http://www.google.com/search?sourceid=navclient-ff&ie=UTF-8&rlz=1B2GGGL_enPH176&q=mktime\()+expects+parameter+4+to+be+long%2C+string+given+in
    how many sites actually display that erorr .. )

    it seems to have to do with incompativble PHP4 code used in easymoblog

    hence my question:

    is anyone using successfully comoblog in a current PHP5 system ??

    as posted much earlier
    http://sourceforge.net/forum/forum.php?thread_id=1428506&forum_id=479691
    all attempts to upgrade failed due to modified table with background
    I have now removed that table entry using

    mysql>

    DELETE FROM easymoblog_preferences WHERE pref_name='CFG_BG_IMG_REPEAT';

    and my heavily SEO-modified version should now be fully compatible for upgrade to comoblog on new server using apache2 / PHP5
    if comoblog is running PHP5

    any successful YES or howto would be apreciated

    hans

     
    • hans
      hans
      2006-10-15

      miracles come sooner than expected

      the php5 issue seems no php issue but a character set issue

      having googled and saw that many have the same error as the blog gives

      in one of the few solution posts found in google
      i saw a post having the same error about the time funtion in php for vbulletin forum

      and the vbulletin man suggested a reinstall using ASCII charset

      hence i restored my mysql blog db using ascii instead of iso-8859-1 as charset of original file and see
      it all works with php5

      Google analytics always shows my blog pages ( all my own system is utf8 ) as ASCII eventhough my (ex-) host (1AND1.COM) insisted to have all mysql in iso-8859-1 collation swedish

       
      • Glad to hear you have it up and running.

        I know that the Setup Wizard has problems with PHP5 that stops someone doing a clean install or an upgrade on a PHP5 system, but by the sounds of things the rest of the application works fine from your tests.

        M.

         
        • iamdecal
          iamdecal
          2006-11-16

          >>>I know that the Setup Wizard has problems with PHP5 that stops someone doing a clean install or an upgrade on a PHP5 system, 

          dont suppose you know what it is do you? i've been bitten by the bug again and am having a go at getting the next release out of the door, but im on php5 now so i cant install ;-(

          iamdecal

           
          • Man, I REALLY need to find a decent host that is running php5 so I can play with it to find out.

            From memory, it's todo with the way we are handling the session as it's where we store what page we are up to ....