#8 Updating with existing modules fails

To_Fix_in_v1.0
closed-fixed
7
2005-11-18
2005-10-15
No

If you are upgrading from a EML051 instance and you have installed
custom modules then the upgrade script doesn't take this into
account and odd things can occur in your sidebar.

We need to analyse how to handle this part of the upgrade and
perhaps how to handle the versioning of modules in the future.

At the very least in 1.0 we should delete all non-standard modules
from the DB upon upgrade and force the user to reinstall.

Discussion

  • Logged In: YES
    user_id=342445

    Added module versioning framework as a basis for this.

     
  • Logged In: YES
    user_id=342445

    Code commited, just need to add some more doco in now.

     
  • Logged In: YES
    user_id=342445

    Doco updated, case closed.

     
    • status: open --> closed-fixed