#2 2 different installations, 2 different detection problems

closed
Pontus Ekberg
5
2008-12-14
2008-02-14
Gabriela Steren
No

1) I'm running Debian Etch and have installed the comix package with aptitude, but when I try to run it, I get the following error:

PyGTK version 2.8.0 or higher is required to run Comix.
No version of PyGTK was found on your system.

I do have PyGTK installed. How can I let comix know where it is?

2) I tried installing it from source. It seems to have no problem finding PyGTK, but instead I get the following error:

Traceback (most recent call last):
File "/usr/bin/comix", line 39, in ?
import gtk
File "/usr/local/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py", line 48, in ?
from gtk import _gtk
ImportError: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: g_type_register_static_simple

I have that symbol defined in /usr/lib/libgobject-2.0.so.0

I would appreciate some help.

Thanks in advance.

Discussion

  • Pontus Ekberg
    Pontus Ekberg
    2008-12-14

    Hi,

    I'm afraid my help is a little late now, so I'll close this. Please feel free to re-open this support request if you still need help.

     
  • Pontus Ekberg
    Pontus Ekberg
    2008-12-14

    • assigned_to: nobody --> herrekberg
    • status: open --> closed
     
  • Pontus Ekberg
    Pontus Ekberg
    2008-12-14

    I might also add that the problem is the Python installation not finding the installed module, it is nothing specific to Comix.