#41 Error opening widget version 1.37

closed
nobody
None
5
2012-10-09
2012-10-08
No

Have uninstalled version 1.36 and then installed new version. Added the
widget.
At first run the widget works good, displaying the entries with correct
dates.
When I try to open the widget (tap on it), the window shows: "Error:
displaying list: TypeError: 'undefined' is not an object, line undefined".
Then returning to the homescreen the widget shows the same error.
After that, i've uninstalled version 1.37 and then installed old version
1.36.
The problem dissapears, and everything went back to normal.

Did some testing. With version 1.37 installed.
Reboot the phone after the error and 'surprise' the widget displays without
errors.
But, again, when I try to open the widget (tap on it), the window shows:
"Error:
displaying list: TypeError: 'undefined' is not an object, line undefined".
Then returning to the homescreen the widget shows the same error.

Log file Attached.

Discussion

  •  
    Attachments
  • Michael Prager
    Michael Prager
    2012-10-08

    Okay thanks, I will take a look.

     
  • Michael Prager
    Michael Prager
    2012-10-08

    Looks like on October 13, you have an anniversary which has a start date but no end date. This messes things up when the event is processed (which currently only happens when you open fullscreen because it displays more events). Any idea how that may have happend?

     
  • Michael Prager
    Michael Prager
    2012-10-08

    Hm no that can't be the cause... odd. Will have to look further.

     
  • Have deleted that entry and surprise!! It starts to work without problems ...
    It's weird.
    Why that entry has no problems with version 1.36 ?

     
  • Add the same entry again, and the problem comes back.

     
  • Michael Prager
    Michael Prager
    2012-10-08

    added more debug output to narrow down the problem

     
  • Michael Prager
    Michael Prager
    2012-10-08

    This is very strange, I don't see why this entry should be a problem. I've attached a modified widget with more detailed debug output. Could you try that and create a new logfile with that? That should help to narrow down the problem.

     
  • new log

     
    Attachments
  • new log added.

     
  • Michael Prager
    Michael Prager
    2012-10-09

    possible fix

     
    Attachments
  • Michael Prager
    Michael Prager
    2012-10-09

    Okay I have attached a possible fix. Please try again. :-)

     
  • Now it works great.
    Thank you Michael.

     
  • Michael Prager
    Michael Prager
    2012-10-09

    • status: open --> closed