#20 A different kind of Error loading calendar service

open-wont-fix
nobody
None
9
2011-05-29
2011-05-29
Ghorian
No

I have reset the phone but the error persists. The message is:

Error loading Calendar Service: ReferenceError: Can't find variable: device. line 869

I'm on ComingNext 1.32, downloaded yesterday. The phone is a C6-01 (Symbian^3)

Discussion

  • Ghorian
    Ghorian
    2011-05-29

    • priority: 5 --> 9
     
  • Michael Prager
    Michael Prager
    2011-05-29

    Did you restore any data after you reset your device? Keep in mind that restoring your files will also restore the cause of the error.

     
  • Ghorian
    Ghorian
    2011-05-29

    No, I did not restore any files because the reset (settings - phone - phone management - factory settings - restore) did not destroy any files as far as I can see. All it did was remove all my home screen modifications, widgets, shortcuts, ringtones and the like.

     
  • Ghorian
    Ghorian
    2011-05-29

    I have tried to look at C:\Private\2000f847 using x-plore but the folder C:\Private\ appears to be empty, or the system won't let me look at what's in there.

     
  • Michael Prager
    Michael Prager
    2011-05-29

    You won't be able to access anything in the C:\Private folder unless you have a hacked firmware. I'm not sure if this the same reset as you already did but give this number a try anyway:

    *#7370#

     
  • Ghorian
    Ghorian
    2011-05-29

    Well, it took me almost two hours to re-customize the pohone the way it was before. So I am hesitant do play with resets a lot.
    The C6-01 FAQ by nokia (see http://europe.nokia.com/support/product-support/c6-01/faq#03 ) says that (settings - phone -
    phone management - factory settings - restore) is equivalent to *#7780#

    What you suggest (*#7370#) will "delete all content from mass memory (E:), also the pre-loaded content including e.g. widgets. The command deletes also all user content from the phone memory (C:). All the settings need to be recreated after the reset and the applications reinstalled."

    Such a serious zap is not an option for me at this time. I am on a long trip in a foreign country currently, I can't spend a day or two to get my phone back into a usable state.

    So, without ComingNext, my calender is quite unusable, but after a brute reset, my phone will be even more unusable.

    Quite frustrating.

     
  • Michael Prager
    Michael Prager
    2011-05-29

    Yes it's not a very pleasant situation. The problem also affects other widgets and Nokia knows about it for some time now, but they didn't fix it yet. Since you can't modify/delete files in C:\private yourself, the only solution is to use the hard reset option to remove all user content from the phone memory (C:). Any other, more "soft" method will not remove the broken config file. There is nothing you or me can do about it.

     
  • Michael Prager
    Michael Prager
    2011-05-29

    • status: open --> closed-wont-fix
     
  • Ghorian
    Ghorian
    2011-05-29

    Could it be that Nokia's S^3 development resources might no longer suffice to work on exotic bugs like this one?

    Can you really not think of a way to configure the "missing device object" (whatever that is) through some creative means of your own - other than through a system config file that has a tendency to get screwed up?

    Because, even if I sacrificed three days to erase and rebuild my phone, the bug could hit me a day later again, no?

    I mean, what does "Resolution:Wont Fix" really mean? Won't fix cause it's their fault, not mine? Or won't fix because it is technically impossible?

     
  • Ghorian
    Ghorian
    2011-05-29

    • status: closed-wont-fix --> open-wont-fix
     
  • Michael Prager
    Michael Prager
    2011-05-29

    The device object is the key component to access anything on the device, like the calendar data. Without access to this, there is no calendar data to display. This device should always be present, but due to this broken config its not. Its true that the error might reappear again after you reset your device. Until we know the exact reason what causes the config to break, you can never to sure. This bug is set to "Won't fix" because there is nothing an application developer like me can do to fix it. Only Nokia can do something about it.

     
  • wolfgang-362
    wolfgang-362
    2011-06-26

    Nokia N8-00 S^3 PR1.2
    Today I got the same error. Which file on Phone Memory (C) do I have to delete to temporarily fix this (ghorian mentioned C:\Private\2000f847)? I know I have to 'jailbreak' the phone to do this.

    Maybe Symbian 'Anna' will have a final fix built in?

     
  • Steve Goodey
    Steve Goodey
    2011-11-21

    Hi, just been hit with this problem on my E7-00 with Symbian Anna! I don't suppose Nokia will have it sorted with Belle. I've gone on the Nokia developer site and added a post hopefully to kick some action but I doubt it.

    I wonder if browsing the phones C drive from Linux would allow overwritting of the bust file?

    Steve.

     
  • Michael Prager
    Michael Prager
    2011-11-21

    The problem persists for over 2 years now, I doubt that Nokia will start solving this now.

    As far as I can tell, the access to protected directories on C drive can only be achived if the firmware is modified.