#2 Error: loading Calendar Service

open-wont-fix
None
6
2011-02-16
2010-02-22
Anonymous
No

Hello,

first sorry for my bad english and thanks
for this great prog.

I'm one of them with the following error:
Error: Loading Calendar Service:
ReferenceError: Can't find variable:
device, line 668

I'm using Epocware Handy Calendar and so I changed the number in
the options (V 1.24).

Perhaps it's very interesting: First it works !!! (Firmware was changed a month
before; V 20.0.19).

I remember that I made a backup and I think after this backup (and a restart
next morning) the error was showing.

Is there any solution for this problem?
Thanks for any help.

Nobbi

Discussion

  • Michael Prager
    Michael Prager
    2010-02-23

    • priority: 5 --> 6
    • assigned_to: nobody --> michaelprager
     
  • I tried this and it works. Thank you.

    Also I make tests and this are my results:
    -First I make a backup to my memory card - all datas
    -*#7370#
    -Then restoring the datas...first calendar, ....... and ....files
    -After restoring files (german version: Dateien) Coming Next didn't work
    -*#7370#
    -Then restoring all datas without 'Dateien'
    -Coming Next works
    -==> restoring phone parameters works on my N97... only restoring files do not

    ...I don't unterstand this..... remember: after update to the new firmware the programm works.....because after this update there was a restoring 'all datas'!!!!!!!!

    It seemed to be a special file that make the problem....and this file came not with the update of the firmware, but later.

    Nobbi

     
  • Michael Prager
    Michael Prager
    2010-10-16

    A fix for this issue it not possible at this stage

     
  • Michael Prager
    Michael Prager
    2010-10-16

    • status: open --> closed-wont-fix
     
  • Michael Prager
    Michael Prager
    2011-02-16

    Non corrupted C:\Private\2000f847 folder

     
    Attachments
  • Michael Prager
    Michael Prager
    2011-02-16

    There are news: according to a user the problem is a result of a file curroption in C:\Private\2000f847. Here is his comment (from http://www.symbian-freak.com/forum/viewtopic.php?p=632658#p632658\):

    "Well, I've found out that the problem is located in the folder C:\Private\2000f847
    There is just a small file called "config.dat" (55 bytes) and a folder with 1 or few small files (229 bytes each) When I overwrite that folder with the same one but not corrupted (the one after a reset) the issue vanish :) This is my folder after a deep reset, so that noone should reset his phone just to make it work again"

    [See 2000f847.zip attached below]

    "Whether someone encounters this problem, please let me know if this folder helps you :)

    NOTE: after replacing the folder, you need to reboot your phone in order to make ComingNext work again"

     
  • Michael Prager
    Michael Prager
    2011-02-16

    • status: closed-wont-fix --> open-wont-fix
     
  • Ghorian
    Ghorian
    2011-06-17

    Success!

    I hacked the phone, resored the C:\Private\2000f847 folder you supplied, and it's working again! Thanks very much.

     
  • HáRoš
    HáRoš
    2011-08-03

    Success! - but another :-)
    On my C6-00 with error "Error: Failed to load settings, calendar entry could not be found".
    There aren´t folder you suplied, so I copied it simply (all the folder) and it works :-)