#3 Zope 2.8.1

1.0alpha2
open
nobody
None
1
2005-12-13
2005-10-19
Jonas Nielsen
No

I have tried to install the product "CMFEditions
1.0_alpha 2" on Plone 2.1

I works fine if it runs on zope 2.7.x, but on Zope
2.8.1 it fails with the following traceback (from
/Control_Panel/Products/CMFEditions):

Traceback (most recent call last):
File
"/var/lib/zope2.8.1/lib/python/OFS/Application.py",
line 695, in import_product
product=__import__(pname, global_dict, global_dict,
silly)
File
"/var/lib/zope2.8.1/instances/sandbox/Products/CMFEditions/__init__.py",
line 35, in ?
from Products.CMFEditions import ZVCStorageTool
File
"/var/lib/zope2.8.1/instances/sandbox/Products/CMFEditions/ZVCStorageTool.py",
line 46, in ?
from Products.ZopeVersionControl.ZopeRepository
import ZopeRepository
File
"/var/lib/zope2.8.1/instances/sandbox/Products/ZopeVersionControl/__init__.py",
line 16, in ?
import ZopeRepository, OFS, App, Globals
File
"/var/lib/zope2.8.1/instances/sandbox/Products/ZopeVersionControl/ZopeRepository.py",
line 19, in ?
import Repository
File
"/var/lib/zope2.8.1/instances/sandbox/Products/ZopeVersionControl/Repository.py",
line 20, in ?
from ZopeVersionHistory import ZopeVersionHistory
File
"/var/lib/zope2.8.1/instances/sandbox/Products/ZopeVersionControl/ZopeVersionHistory.py",
line 18, in ?
import VersionHistory
File
"/var/lib/zope2.8.1/instances/sandbox/Products/ZopeVersionControl/VersionHistory.py",
line 18, in ?
from EventLog import EventLog, LogEntry
File
"/var/lib/zope2.8.1/instances/sandbox/Products/ZopeVersionControl/EventLog.py",
line 17, in ?
from Utility import _findUserId
File
"/var/lib/zope2.8.1/instances/sandbox/Products/ZopeVersionControl/Utility.py",
line 16, in ?
from ZODB.referencesf import referencesf
ImportError: No module named referencesf

Discussion

  • Jonas Nielsen
    Jonas Nielsen
    2005-10-19

    • priority: 5 --> 8
     
  • DaftDog
    DaftDog
    2005-10-26

    Logged In: YES
    user_id=1290240

    Hi,
    Had the same problem with 2.8.1 (and Plone 2.1) but I could
    get past that by getting a newer version of
    ZopeVersionControl and replacing the old one. CMFEditions
    seems to work fine then, but the "Compare" button shown in
    the screenshots doesn't show up and using the "View"
    function gives me the following error:

    Traceback (innermost last):
    Module ZPublisher.Publish, line 113, in publish
    Module ZPublisher.mapply, line 88, in mapply
    Module ZPublisher.Publish, line 40, in call_object
    Module Shared.DC.Scripts.Bindings, line 311, in __call__
    Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
    Module Products.CMFCore.FSPageTemplate, line 188, in _exec
    Module Products.CMFCore.FSPageTemplate, line 127, in pt_render
    Module Products.PageTemplates.PageTemplate, line 102, in
    pt_render
    - <FSPageTemplate at /Plone/versions_history_form used
    for /Plone/front-page>
    Module TAL.TALInterpreter, line 206, in __call__
    Module TAL.TALInterpreter, line 250, in interpret
    Module TAL.TALInterpreter, line 709, in do_useMacro
    Module TAL.TALInterpreter, line 250, in interpret
    Module TAL.TALInterpreter, line 426, in do_optTag_tal
    Module TAL.TALInterpreter, line 411, in do_optTag
    Module TAL.TALInterpreter, line 406, in no_tag
    Module TAL.TALInterpreter, line 250, in interpret
    Module TAL.TALInterpreter, line 740, in do_defineSlot
    Module TAL.TALInterpreter, line 250, in interpret
    Module TAL.TALInterpreter, line 426, in do_optTag_tal
    Module TAL.TALInterpreter, line 411, in do_optTag
    Module TAL.TALInterpreter, line 406, in no_tag
    Module TAL.TALInterpreter, line 250, in interpret
    Module TAL.TALInterpreter, line 688, in do_defineMacro
    Module TAL.TALInterpreter, line 250, in interpret
    Module TAL.TALInterpreter, line 732, in do_defineSlot
    Module TAL.TALInterpreter, line 250, in interpret
    Module TAL.TALInterpreter, line 675, in do_condition
    Module TAL.TALInterpreter, line 250, in interpret
    Module TAL.TALInterpreter, line 426, in do_optTag_tal
    Module TAL.TALInterpreter, line 411, in do_optTag
    Module TAL.TALInterpreter, line 406, in no_tag
    Module TAL.TALInterpreter, line 250, in interpret
    Module TAL.TALInterpreter, line 426, in do_optTag_tal
    Module TAL.TALInterpreter, line 411, in do_optTag
    Module TAL.TALInterpreter, line 406, in no_tag
    Module TAL.TALInterpreter, line 250, in interpret
    Module TAL.TALInterpreter, line 709, in do_useMacro
    Module TAL.TALInterpreter, line 250, in interpret
    Module TAL.TALInterpreter, line 477, in do_setLocal_tal
    Module Products.PageTemplates.TALES, line 221, in evaluate
    - URL:
    file:CMFEditions/skins/cmfeditions_views/version_document_view.pt
    - Line 133, Column 14
    - Expression: <PythonExpr len(here.text)>
    - Names:
    {'container': <PloneSite at /Plone>,
    'context': <ATDocument at /Plone/front-page>,
    'default': <Products.PageTemplates.TALES.Default
    instance at 0xb725526c>,
    'here': <ATDocument at /Plone/front-page>,
    'loop': <Products.PageTemplates.TALES.SafeMapping
    object at 0xb3638b0c>,
    'modules':
    <Products.PageTemplates.ZRPythonExpr._SecureModuleImporter
    instance at 0xb71d95ac>,
    'nothing': None,
    'options': {'args': ()},
    'repeat': <Products.PageTemplates.TALES.SafeMapping
    object at 0xb3638b0c>,
    'request': <HTTPRequest,
    URL=http://localhost:8080/Plone/front-page/versions_history_form>,
    'root': <Application at >,
    'template': <FSPageTemplate at
    /Plone/versions_history_form used for /Plone/front-page>,
    'traverse_subpath': [],
    'user': admin}
    Module Products.PageTemplates.ZRPythonExpr, line 47, in
    __call__
    - __traceback_info__: len(here.text)
    Module Python expression "len(here.text)", line 1, in
    <expression>
    AttributeError: text

    Is CMFEditions still maintained at all? Would be a shame if
    not...

     
  • Alec Mitchell
    Alec Mitchell
    2005-12-12

    Logged In: YES
    user_id=70421

    As indicated above this means you need a newer version of
    ZopeVersionControl (from zope CVS). Hopefully we can get
    the 2.8 compatible version packaged into a release. In
    theory the CMFEditions 1.0 release shouldn't depend on
    ZVC. Do not fear CMFEditions is maintained, keep in mind
    user testing is important to hunting these things down.

     
  • Alec Mitchell
    Alec Mitchell
    2005-12-13

    • priority: 8 --> 1
     
  • Alec Mitchell
    Alec Mitchell
    2005-12-13

    Logged In: YES
    user_id=70421

    Please file an separate issue regarding your issue with
    the view link, and provide more details about the object
    you are trying to view. My guess is that it is not a
    document/page, correct?