#605 Second "saved search" saving fails

closed-fixed
Andreas Jung
5
2006-12-08
2006-12-08
Anton Georgiev
No

When saving a "saved search" only the first one saves fine. Cannot save a second "saved search".

Zope 2.9.4
Plone 2.5.1
PCNG 1.2.10b1
TING 3.1.11

---

Site Error

An error was encountered while publishing this resource.

AttributeError
Sorry, a site error occurred.

Traceback (innermost last):

* Module ZPublisher.Publish, line 194, in publish_module_standard
* Module Products.PlacelessTranslationService.PatchStringIO, line 34, in new_publish
* Module ZPublisher.Publish, line 146, in publish
* Module Zope2.App.startup, line 222, in zpublisher_exception_hook
* Module ZPublisher.Publish, line 115, in publish
* Module ZPublisher.mapply, line 88, in mapply
* Module ZPublisher.Publish, line 41, in call_object
* Module Products.CMFCore.FSPythonScript, line 108, in __call__
* Module Shared.DC.Scripts.Bindings, line 311, in __call__
* Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
* Module Products.CMFCore.FSPythonScript, line 164, in _exec
* Module None, line 23, in pcng_save_search
<FSPythonScript at /box/pcng_save_search used for /box/projects/SAS/plonecollectorng.SAS.BASE>
Line 23

AttributeError: 'tuple' object has no attribute 'append'

Discussion

  • Andreas Jung
    Andreas Jung
    2006-12-08

    Logged In: YES
    user_id=11084
    Originator: NO

    Fixed on the 1.2 branch

     
  • Andreas Jung
    Andreas Jung
    2006-12-08

    • status: open --> closed-fixed