Collada DOM sources compilation with MinGW

Help
2011-10-30
2013-05-01
  • I try to make compilation for COLLADA DOM 2.3.1 sources for DOM subproject..
    BUT I have problem in daeLIBXMLPlugin.cpp with XML_PARSE_HUGE..It's not defined in any include files…
    BUT XML_PARSE_HUGE are defined in external libs in project libxml2-new…(parser.h & parserInternals.h)
    BUT this project does't have sources *.cpp files and compiled for mingw libraries…

    What must I do..
    PLEASE..help me..may you may add needed sources to resolve this problem…

    Best regards,
    Alexander Bychkov

     
  • Marek Kijo
    Marek Kijo
    2012-01-12

    Hello, at first I had the idea to add (as hardcoded couple of lines) to daeLIBXMLPlugin.cpp a definition of XML_PARSE_HUGE as 1<<19, but i dont think that is a got start:). so i've checked some included files, there are two folders with headers for libxml2: libxml2 and libxml2-new. Defaultly compilation is set to use libxml2 (where is no definition of XML_PARSE_HUGE ???), so I had changed these settings like this:

    file: dom/make/dom.mk --->
    
    old line 24: includeOpts += -Iexternal-libs/libxml2/include
    
    new line 24: includeOpts += -Iexternal-libs/libxml2-new/include
    
    old line 25: libOpts += -Lexternal-libs/libxml2/$(buildID)/lib -lxml2 -lws2_32 -lz
    
    new line 25: libOpts += -Lexternal-libs/libxml2-new/$(buildID)/lib -lxml2 -lws2_32 -lz
    
    old line 27: includeOpts += -I/usr/include/libxml2
    
    new line 27: includeOpts += -I/usr/include/libxml2-new
    
    file: dom/make/minizip.mk --->
    
    old line 21: libOpts += -Lexternal-libs/libxml2/mingw/lib
    
    new line 21: libOpts += -Lexternal-libs/libxml2-new/mingw/lib
    
    old line 24: # libOpts += -Lexternal-libs/libxml2/mingw/lib
    
    new line 24: # libOpts += -Lexternal-libs/libxml2-new/mingw/lib
    

    line 24 is in fact commented but for future comfort… :)
    Those changes should elegantly fix that problem:)

    BR,
    Marek Kijo

     
  • Marek Kijo
    Marek Kijo
    2012-01-12

    I've just checked some news and this bug is probably fixed already, so try to checkout new repo.