#13 version 'GLIBC_2.3' not found

closed
nobody
None
6
2005-06-23
2005-04-07
Rich The Hack
No

Hi,
I am running Colinux 2.6.8.1-co-0.6.2-pre6. I am
trying to port over an application from Redhat Linux.
When starting the appl, I am receiving:

/lib/libc.so.6: version 'GLIBC_2.3' not found

Any ideas how to resolve this? Many thanks.
Rich

Discussion

  • Rich The Hack
    Rich The Hack
    2005-04-13

    • priority: 5 --> 6
     
  • Logged In: YES
    user_id=30412

    This is not an coLinux error/problem. Sounds like the
    version of GLIBC on the image you tried was different than
    the one you built the application against.

     
    • status: open --> closed
     
  • peter green
    peter green
    2005-06-23

    Logged In: YES
    user_id=418950

    what root filesystem image are you using with colinux?

    that kind of message is generally the result of trying to
    bring a binary from a newer distro to an older distro if you
    wan't to build binaries that will work on older distros look
    into autopackages apbuild.