Hi,

I am quite sure that it is a problem with something related to the ATI card and my graphics driver, because my computer crashed differently before and after I upgraded my drivers, and both times Windows reported to me that the display driver had crashed (previously in a BSOD, after upgrading, as a system tray message). Both times my mouse would barely move, and both times my screen would go black for a long period of time.

I went to the link you specified. I opened up an admin CMD, and cd'ed to "C:\Program Files\andLinux". There I first ran "colinux-daemon" and "colinux-daemon --status-driver". Both commands reported the date of compilation (i.e. the former said "Daemon compiled on" and the latter said "Driver compiled on") as "Wed Apr 15 18:59:08 2009". I then ran the command "colinux-daemon kernel=vmlinux initrd=initrd.gz root=/dev/ram0", which failed with the message "initrd.gz: The system cannot find the file specified". A "dir" showed that the file vmlinux exists but the file initrd.gz does not. Running startup.bat opens up another console window. The display driver crashes immediately after it finds the TAP-CoLinux driver.

Thanks for replying; andLinux was just an experiment for me, just to see if it worked, and how well it worked. It doesn't matter to me much; I can always use VirtualBox in Seamless Mode.

On Wed, Nov 17, 2010 at 5:24 PM, Henry Nestler <henry.ne@arcor.de> wrote:
Hello Anirudh,


On 17.11.2010 00:45, Anirudh Bagde wrote:
Hi,

I don't know where to ask this or whether to file a bug report, so I decided to post it here. I recently installed andLinux Beta 2 (final) downloaded from the andLinux downloads page. I verified its MD5 and SHA1 hashes using HashTab, and I successfully installed it. All the shortcuts and icons and explorer extensions are now working. However, the colinux daemon is not. The service is on manual startup. Every time I open up services.msc and start the service andLinux, the display goes black within a minute and then shoes a BSOD with a stop error 116. It says that the display driver stopped working and could not be restarted. My display driver is and ATI Radeon X1200. After upgrading the ATI driver to 10.02 and reinstalling the coLinux driver, all this still happens, except I do not get a BSOD. The screen goes blank and the cursor (which I cannot move) flashes on and off. Then the screen comes back, and there is a message coming from the system tray that says the ATI display driver crash and recovered. However, I still cannot move the mouse, and the screen goes black again. This process keeps repeating until I manually held the power button and turned off the computer.

My computer is a Windows Vista Home Premium 32-bit with Service Pack 2. The graphics card is an ATI Radeon X1200. There are lots of driver files loaded as reported by Device Manager. The driver version is 8.593.100.0, and the Catalyst Control Center version is 2010.0210.2339.42455. The computer is a Toshiba Satellite A215-S7411. The processor is AMD Athlon(tm) 64 X2 Dual-Core Processor TK-53 running at 1.70 GHz. I have about 240 GB of hard drive and 4 GB of RAM.

Is there any more information I need to provide? And does anyone know if there is anything I can do to get andLinux and coLinux to work?

I think, there exist no solution.

I see you have 4GB RAM and a Windows 32 bit. Windows use some dirty tricks to access full 4GB, while hardware can only access ~3,5GB of RAM directly. If Windows now give coLinux this dirty memory, then it will crash.
The dirty trick is named AWE, please read last articles from this Open Discussion "How to let coLinux run in large RAM (>4GB)":
https://sourceforge.net/projects/colinux/forums/forum/342354/topic/3467832

Other problem can be ATI card. If that card uses shared memory and not marked this memory correctly as "used by graphic card", then coLinux would attach this memory and will later crash.
-- 
Henry N.



--
I'm an FSF member -- Help us support software freedom!