It does have a drive letter in windows, but I haven't had any problems with it.  I would use cofs, but if I can be blunt, I found it pretty useless because I got "Fsync failed" when I tried to do anything useful.  For example, I got that error when I tried to edit a file in vim, and also got it when I tried to run /script/server in a ruby application, which runs a light web server to test a ruby on rails application.  But I guess it's useful for straight copies.

Ok then, can we give cofs a uuid?  That way I can use the same /etc/fstab file which specifies the uuid now instead of a /dev/.. path.

-Andrew

On Fri, Mar 21, 2008 at 8:23 AM, Henry Nestler <Henry.Ne@arcor.de> wrote:
Andrew Roth wrote:
> Hi all,
>
> Is it possible to give a uuid on the config / command line in a similar
> way that you can give an eth device a MAC address?
>
> ex
>
> hda3=\Device\Harddisk0\Partition3, 94749C99749C7FA2 # <-- specify uuid
>
> where the line in fstab is
>
> # /dev/sda3
> UUID=94749C99749C7FA2 /media/sda3     ntfs    defaults,umask=007,gid=46 0
>
> Because for some reason my ntfs partitions get a different uuid in
> colinux.  Actually, I would be interested to know if that would be a bug
> or not.

The UUID is reading from filesystem, are some bytes from filesystem
superblock and is named GUID of volume.

Big warning! Don't mount a ntfs partition, if it is online in Windows
(have a drive letter). You risk reading wrong datas.

You should use cofs for accessing this drive.

--
Henry N.