Hi,

I have solve this problem. It is caused by the network device changed.It can be solved as following:

Edit file /lib/udev/rules.d/75-persistent-net-generator.rules and set a bypass for coLinux in same way as xen or UML does it

======================================================

--- /lib/udev/rules.d/75-persistent-net-generator.rules.orig

+++ /lib/udev/rules.d/75-persistent-net-generator.rules

@@ -23,6 +23,9 @@

 # ignore Xen virtual interfaces

 SUBSYSTEMS=="xen", GOTO="persistent_net_generator_end"

 

+# ignore coLinux virtual interfaces

+DRIVERS=="conet", GOTO="persistent_net_generator_end"

+

 # read MAC address

 ENV{MATCHADDR}="$attr{address}"

======================================================

Remove the file “/etc/udev/rules.d/70-persistent-net.rules”.

 

Please refer: http://colinux.wikia.com/wiki/Fedora11Minimal

 


发件人: 余松 [mailto:szyusong@163.com]
发送时间: 2011年8月14 1:22
收件人: colinux-users@lists.sourceforge.net
主题: The network does not work ok when run as service, why?

 

Hi,

I make a new colinux file system of debian 6.0.2 using debootstrap.

When I start the colinux from command line, the network is ok, the ping is ok.

But when I run the colinux as service, the network can not ping ok.

 

Thanks.