Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Network Nat, colinux0.61 Debian how to setup?

Help
Charlie
2004-10-02
2013-05-09
  • Charlie
    Charlie
    2004-10-02

    I have installed colinux0.61 with debian on Windows XP. Beacuse my LAN provider allows only one ip fo my computer i had to use NAT Network.
    I setuped it like it was in manual untill i had to write my IP address of the DNS of my ISP.
    I'm using DHCP and i don't know my ip and DNS because on Windows it is setup automatically.

    after typing ipconfig on my xp i got

    Local Nethwork
            DNS Sufix : . . . . . . . . .  . ists.
            IP Address. . . . . . . . . . . . . : 192.168.15.xxx
            Subnet Mask. . . . . . . . . . : 255.255.255.0
            Gateway. . . . . . . . . . : 192.168.15.xxx

    TAP
            DNS Sufix
            IP Address. . . . . . . . . . . . . : 192.168.0.1
            Subnet Mask. . . . . . . . . . : 255.255.255.0
            Gateway. . . . . . . . . . :

    and there is no information about my ISP DNS ip.

    Now i can only use ping to any ip address but not hosts (XXX.XXX.XXX.XXX not google.pl).
    Maybe helps also you to solve my problem that fact :
    when i connet via ftp on debian to any ip i can only login, when i trying usin ls or dir or anything else i get
    >
    >ftp ls
    >200 PORT command successful
    >425 Could not open data connection to port 5001: No rout to host

    i can't also use apt-get ieven if change al host to ip addres :(

    any suggestion, i'm tired with this problem and searching solution....

     
    • Mikel Nies
      Mikel Nies
      2004-10-03

      U could also use XP's ICS, just set tap manual to 192.168.0.1 and set subnet to 255.255.255.0
      Then open properties of your LAN connection, go to advanced tab and turn on "Allow other network users to connect through this comp's internet conn"

      If Debian's network is setup right this should work.

       
    • Charlie
      Charlie
      2004-10-03

      i have setuped it like this....
      and i can ping to each other by ip.
      Even i can ping to any ip in thernet, by when i try to use host name it's not found.
      and i can't use almost all ports ? why?

       
    • Mikel Nies
      Mikel Nies
      2004-10-03

      In windows command prompt do "ipconfig /all" then ull get the DNS IP, enter the DNS IP in /etc/resolv.conf.

      As for the ports, maybe windows firewall is turned on?

       
    • Charlie
      Charlie
      2004-10-03

      thanks, i didn't know that ipconfig has "all" atribute.
      Unfortunately wrtiting this dns ip to /etc/resolve.conf didn't help....
      still can't resolve host name......

      how to turn off this windows firewall i don't know if it is set on.

       
    • Mikel Nies
      Mikel Nies
      2004-10-03

      Windows firewall is in the LAN settings, on the same tab as ICS.

      Im sorry to see it doesnt work now, i wouldnt know what u can do more. Maybe someone who knows more about networking drops by...

       
    • Charlie
      Charlie
      2004-10-03

      it was turn off so i also have no idea why it doesn't work....

      thanks jackhair maybe someone else have any ideas?

       
    • intradink
      intradink
      2004-10-06

      try putting a public dns server ip address (google to find one) in /etc/resolv.conf

      or you could try just enabling dhcp and not setting static addresses.  This way coLinux should attempt to try and find it's settings from the network.

       
    • Niraj Kale
      Niraj Kale
      2004-10-07

      I had the same problem! I am using a router with DHCP.
      I tried to use NAT and windows bridge. Don't work.
      Finally i used
      <network index="0" type="bridged" name-"Linksys LNE100TX Fast Ethernet"/>
      and uninstalled TAP-Win32 adapter.
      and it is working fine !