Redirecting X

Help
River~~
2012-03-19
2013-05-09
  • River~~
    River~~
    2012-03-19

    I have installed Colinux, Squeeze, and Xming.

    I have Squeeze working in the command line, and am stuck on getting X to display on Windows.

    I have set up eth1=tuntap, with 192.168.3.1 being the address of the Debain end of the connection, and 192.168.3.2 the Windows end. Ping works from one to the other, so I am confident about networking.

    I start Xming in single window mode, display 0.

    From root in Debian I run

    DISPLAY=192.168.3.2:0.0
    gdm

    and it complains that there is something wrong with the X server. What else do I need to set, please

    River~~

     
  • Henry N.
    Henry N.
    2012-03-19

    Environment can see from apllication only, if the variable is expored or it is in same line with the commandn.
    Try

    export DISPLAY=192.168.3.2:0.0
    xclock
    

    or

    DISPLAY=192.168.3.2:0.0 xclock
    
     
  • Henry N.
    Henry N.
    2012-03-19

    On the Windows side you must xming start with “-ac” parameter to disable access control restrictions.