Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Gentoo: no eth0

Help
phries
2007-04-15
2013-05-09
  • phries
    phries
    2007-04-15

    I've tried following all the Wiki advice I could but all I ever have in ifconifg is the loopback!  There are no eth devices in /dev.

    Here's my config:
    <colinux>
        <block_device index="0" path="\DosDevices\c:\Program Files\coLinux\Gentoo-2005.1-stage3-ext3" enabled="true" />
        <block_device index="1" path="\DosDevices\c:\Program Files\coLinux\swap_device" enabled="true" />
        <bootparams>root=/dev/cobd0</bootparams>
        <initrd path="initrd.gz" />
        <image path="vmlinux" />
        <memory size="128" />
        <network index="0" type="bridged" name="3C905"/><!-- mac="00:4A:41:52:45:52"/>-->
    </colinux>

    Initrd may not be working: "Trying to move old root to /initrd ... failed", could that have to do with it? (I don't quite understand what initrd does.)  There are also some EXT3-fs errors about "maximal mount count reached" and earlier a ReiserFS error on cobd0--don't know why it would try to use that.

    So where do I find myself an eth0?

     
    • Henry N.
      Henry N.
      2007-05-11

      On booting you should see an error message from colinux-daemoon about your wrong configs.
      For the "bridged" you need to install library WinPcap (DLL) http://winpcap.mirror.ethereal.com/

      The initrd does only copy the modules into your current root fs to /lib/modules.  You can disable initrd after the first run.

      To solve your fs warning, set bootparams to "ro init=/bin/sh" and no initrd, please.
      On the prompt then run 'fsck.ext3 / -f' (or ext2, if you have). After finish run 'sync' and press CTRL-D to exit this linux.  Next boot (without init=...) should run normal.