Colinux-daemon firewall exception

Help
2010-07-26
2013-05-09
  • Marian Vittek
    Marian Vittek
    2010-07-26

    Hello,

    I am new to coLinux, but it seems like a really great tool. I've just one issue with it. When installing/starting
    colinux, it seems to register a firewall exception causing Windows to open a warning dialog which I have
    to confirm.  However, even if I click "continue blocking" on this dialog and firewall exception is not
    allowed, everything work fine with my coLinux installation. Is it be possible to prevent coLinux of
    registering this firewall exception when it is probably not needed? Or is this exception necessary?

    I want to prepare coLinux distribution for other people and I do not want them to be worried about the
    security of their computer when using coLinux. This security dialog surely makes them worry a bit :).

    Thanks in advance,

    Marian

     
  • Henry N.
    Henry N.
    2010-07-26

    coLinux does not try to configure your firewall.

    Of curse coLinux use some network stuff. If you enabled the "tap", then the installer will create a new network device "TAP-Win32". This can effect the firewall. If you not need the TAP device, then you should this daemon disable from installer.

    I never have seen a firewall exceptions on normal installing. Of curse, if you used the image-downloader from inside the installer, then such message can be have.

    From starting coLinux the firewall can popup, if you have enabled some networking devices. This depends on your default settings for the firewall. On my machines I allowed all programs the outgoing traffic, so firewall will not pop up on start. But if I enable redirections on the SLiRP device, then my firewall will warned me. That is normal.

    What is the exact message from firewall? (Program will access network, program will run as server, or …)
    Which daemon program creates the message? colinux-daemon.exe or any of the network daemons, or the installer self?

     
  • Marian Vittek
    Marian Vittek
    2010-07-27

    Hello,

    thanks for the fast answer. Here is what I did:

    1.) I am not sure if this is related to my problem, anyway the installer did not allow me to disable TAP device. It did not give me any choice and simply tried to install it. I've received a security warning during installation and answered negative, so the installation of TAP device did not passed.

    2.) I've copied the whole colinux directory to another machine and typed:

      colinux-daemon -install-driver

    and then:

      colinux-daemon -t nt @debian.conf

    at this second command a dialog entitled "Windows Security Alert" appears saying:

    "
    To help protect your system, Windows Firewall has blocked some features of this program

    Do you want to keep blocking this program?

    Name: colinux daemon program
    Publisher: Unknown

    Windows Firewall has blocked this program from accepting connections from the Internet or a network. If you recognize the program or trust the publisher, you can unblock it. …
    "
    There are 3 buttons: "Keep Blocking", "Unblock" and "Ask Me Later".

    If I click "Unblock" a security exception is added to my firewall and this dialog does not appear on next colinux starts. The security exception is for the program "colinux daemon program".

    If I click "Keep blocking" nothing is added to the firewall, colinux works as fine as before, but the dialog reappears on the next start.

    I do not use TAP device in my configuration, I am using slirp and redirect some ports. I did explicitly opened those ports in the firewall (otherwise the connections were not accepted even with the "colinux daemon program" exception in firewall). I am using Windows-XP with (I think) SP2.

    Best regards,

    Marian

     
  • Henry N.
    Henry N.
    2010-07-27

    1) I've received a security warning during installation and answered negative, so the installation of TAP device did not passed.

    In the installer 3rd page "Select component to install" you must open the tree (click the ). Than disable "Virtual Ethernet Driver (coLinux TAP-Win32)". Then you would never install the TAP driver, and you would not have the security warning from unsigned driver (you have disallowed later).
    This all is for the TAP driver, used by colinux-net-daemon.exe. Ok, here you have no firewall messages, because you have not used it.

    2.) colinux-daemon -t nt @debian.conf
    at this second command a dialog entitled "Windows Security Alert"

    Name: colinux daemon program
    Publisher: Unknown
    Windows Firewall has blocked this program from accepting connections from the Internet or a network.

    The colinux-daemon.exe does not open ports as network server, and has no networking inside. I'm not know, why Windows thinks, we would need this.

    Please try this minimal configuration:

    colinux-daemon kernel=vmlinux initrd=initrd.gz root=/dev/ram0
    

    What Windows version and Service pack you have?

     
  • Marian Vittek
    Marian Vittek
    2010-07-27

    Hello,

    So you must open the tree (click the ).

    actually, this was the problem. I did not have the idea to click on the '+'.  My apologies, I am a newbie :). When un-selecting the TAP device everything works perfectly with no warning messages.

    Many thanks,

    Marian

     
  • Henry N.
    Henry N.
    2010-07-27

    Name: colinux daemon program

    I think, the message is from SLiRP (colinux-slirp-net-daemon.exe), not from colinux-daemon.exe
    All daemon programs have the same description, so you can not different the exactly daemon in the Firewall Popup. I think, we should change the text to better reflect to the user.

    Please go to the machine, you have disallowed the access ones. Open the Windows Firewall settings. In the second register "Exeptions" you will have a list of programs. There you will see one or more "coLinux daemon program". For eatch of this, please click "Edit properties…" (I'm not know the right translation, I have no english Windows). In the next box you will see the path and program name.
    If there is "C:\colinux\colinux-slirp-net-daemon.exe", then it is ok. This was listed there, because you have "redirections" for the SLiRP device.

     
  • Marian Vittek
    Marian Vittek
    2010-07-27

    Hello,

    actually, you are right, the program listed in the firewall is "C:\colinux\colinux-slirp-net-daemon.exe"
    and the dialog reappears when I redirect a new port. Interesting that if the port is listed in exceptions previously, the dialog does not appear.

    Best,

    Marian

    fine now without any exception.

     
  • Henry N.
    Henry N.
    2010-07-27

    New build will print better file description now, for example "coLinux SLiRP Network daemon program".
    see http://www.colinux.org/snapshots/