SIOCSIFADDR: No such device

Help
Alex F
2008-03-25
2013-05-09
  • Alex F
    Alex F
    2008-03-25

    Hi,

    I'm trying to establish communication between coLinux and the host OS (XP pro) using TAP. I'm new to this, so some dumb questions are possibly to follow.

    Preliminary info:

    coLinux version: 0.7.2
    host OS: Windows XP Pro SP 2
    rootfs: Debian-4.0r0-etch.ext3.1gb

    My config file doesn't look too different from example.conf. I'm trying to use TAP on eth1, ie:
    eth1=tuntap

    Basic problem
    -------------

    When I run coLinux I get the following on the console:

    Setting up networking....
    Configuring network interfaces...SIOCSIFADDR: No such device
    eth1: ERROR while getting interface flags: No such device
    SIOCSFNETMASK: No such device
    eth1: ERROR while getting interface flags: No such device
    Failed to pring up eth1.

    (Aside: Where does this get logged?)

    Gory details
    ------------

    On the XP side my coLinux TAP connection IP is set to 192.168.0.1
    On the coLinux side, /etc/network/interfaces:

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface (slirp)
    auto eth0
    iface eth0 inet static
       address 10.0.2.15
       broadcast 10.0.2.255
       netmask 255.255.255.0
       gateway 10.0.2.2

    # Second network (tap-win32)
    auto eth1
    iface eth1 inet static
       address 192.168.0.40
       netmask 255.255.255.0
       gateway 192.168.0.1

    XP> ipconfig /all

    Ethernet adapter coLinux TAP:

            Connection-specific DNS Suffix  . :
            Description . . . . . . . . . . . : TAP-Win32 Adapter V8 (coLinux)
            Physical Address. . . . . . . . . : 00-FF-26-86-90-4B
            Dhcp Enabled. . . . . . . . . . . : No
            IP Address. . . . . . . . . . . . : 192.168.0.1
            Subnet Mask . . . . . . . . . . . : 255.255.255.0
            Default Gateway . . . . . . . . . :

    debian:~# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:FF:A2:CF:A9:80
              inet addr:10.0.2.15  Bcast:10.0.2.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:103 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:25544 (24.9 KiB)  TX bytes:0 (0.0 b)
              Interrupt:2

    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

    What other info would be useful?

    Any suggestions on how I should analyse this problem further are very welcome.

    Thank you,
    Alex

     
    • Henry N.
      Henry N.
      2008-03-29

      Hello,

      First check, that you not have problems with increasing ethX from random created MAC!
      See Bug [ 1861876 ] 20071203-Snapshot -- ifconfig reports no networking
      http://sourceforge.net/tracker/index.php?func=detail&aid=1861876&group_id=98788&atid=622063

      Have you network interfaces eth2 or grater under "cat /proc/net/dev"?
      If yes, than you have incrasing ethX devices. Please follow the "Release Notes" for Debian 4.0:
      http://sourceforge.net/project/shownotes.php?release_id=248895&group_id=98788

      If the above is not your problem, check the config again.
      Stays "eth1=tuntap" at beginning of line without the comment character "#"?

      Enable verbose mode with "colinux-daemon -v 3 ..." to see more about your config.
      Watch for the network start messages from colinux-daemon boot console. You should see
        colinux-net-daemon: auto selecting TAP
        ...
        colinux-net-daemon: found TAP device named "coLinux TAP"
        ... the final message is
        colinux-net-daemon: enabling TAP...

      A typically log with eth0=slirp, eth1=tuntap and eth2=pcap-bridge is here:
      http://www.henrynestler.com/colinux/screenshoots/suse90-colinux-0.7.3-bootlog.txt

      I see, you have a space in name! Some versions have problem with it, if you have config file with name for tap.

      Other problem (after you would have eth1) is that you should not set default-gateway to tap in same time you would use slirp on eth0. Please remove this line:
        gateway 192.168.0.1

      PS: Forums are not very active. Better you use users mailing list.

       
    • Alex F
      Alex F
      2008-04-14

      Thank you very much for your advice.

      I will start working out the problem as soon as I get some spare time (not much of it at the moment)   :S