Network trouble with services

Help
hagan
2008-12-12
2013-05-09
  • hagan
    hagan
    2008-12-12

    So i've got this strange problem, the network interface stops working if i'm running colinux as a service (no eth0 device on debian).  However, if i run the very same conf file from the command line, the network works fine... A while back, running the service worked too, but lately things aren't working so well.. I was suspicious an update to windows broke something, and I've gone so far as to reinstall everything (colinux,winpcap etc...) but nothings fixed it yet.

    So my next thought is something might be configured wrong with the service, but I'm not sure where to go with that.  Has anyone had a similar problem or might know what trouble i'm having? 

    my network line looks like:

    eth0=pcap-bridge,"lan",XX:XX:XX:XX:XX:XX,

    where the X's match my networks mac address....

    And i'm calling my conf file by:
    colinux-daemon.exe @d:\coLinux\server.conf --install-service "Colinux Server"
    net start "Colinux Server"

    Any incite is appreciated.

     
    • Henry N.
      Henry N.
      2008-12-13

      > eth0=pcap-bridge,"lan",XX:XX:XX:XX:XX:XX,
      > where the X's match my networks mac address....

      Oh oh! I hope the XX does not exactly match your real hardware network card. It can not work, if you would have two cards (1 real + 1 virtual) with same mac number.

      Have you upgraded coLinux, or moved linux.sys or the daemons? Then try steps
        colinux-daemon.exe --remove-driver
        colinux-daemon.exe --install-driver

      Create the service entry new, after removing the old:
        colinux-daemon.exe --remove-service "Colinux Server"
        colinux-daemon.exe @d:\coLinux\server.conf --install-service "Colinux Server"

      What coLinux version?
      If 0.8.0: Please check, that this is not the problem from udev. Rund "cat /proc/net/dev" to see what number has the eth. The problen from /etc/udev/rules.d/z25_persistent-net.rules

      The "run as service" and the desktop runs from different Windows user accounts. Perhaps you can enable the "allow interactivity between Service and desktop" for the service "Colinux Server". This can set from service control applet. After this would see a command prompt from colinux-daemon after start this service. Watch these outputs for errors.

      Set your current user (or Administrator) to use with this Service. If that works, then it is a problem with user accounts. For coLinux it es no matter to run as User or as System. Use that, if that works.

      Last, you can uninstall and reinstall the libpacap again.

      Hope one of the tips helps.

       
      • hagan
        hagan
        2008-12-15

        Oops, my mistake.. Those X's don't match my real nic, but a virtual one I made up... With your advice I was able to resolve my problem.  I think it was a driver issue, likely something I broke a while ago... Funny thing was it worked from the command prompt but not the service.  After I upgraded to 0.8.0 the network started working again.  

        When I was running 0.7.3 and I tried to remove the drivers via the "colinux-daemon.exe --remove-driver" command it gave me a message that it had trouble finding the files but would remove anyways...  Sorry, i don't have exact quotes.   Installing gave me a message that the drivers were already in place.

        Thanks Henry!

        -hagan

         
      • hagan
        hagan
        2008-12-16

        Oops, my mistake.. Those X's don't match my real nic, but a virtual one I made up... With your advice I was able to resolve my problem.  I think it was a driver issue, likely something I broke a while ago... Funny thing was it worked from the command prompt but not the service.  After I upgraded to 0.8.0 the network started working again.  

        When I was running 0.7.3 and I tried to remove the drivers via the "colinux-daemon.exe --remove-driver" command it gave me a message that it had trouble finding the files but would remove anyways...  Sorry, i don't have exact quotes.   Installing gave me a message that the drivers were already in place.

        Thanks Henry!

        -hagan