Comment out intird?!?!

Help
eddy556
2007-03-06
2013-05-09
  • eddy556
    eddy556
    2007-03-06

    When executing the command: colinux-daemon.exe -t fltk -c default.colinux.xml the coLinux window starts up and begins to boot.

    During boot the following error occurs:

    -------------------------------------------------------------------------
    Determing/, Found.
    Mounting /
    mount: Mounting /dev/cobd0 on /mnt/linux failed: No such device
    Closing /

    umount: forced umount of (null) failed!
    Failed. (trying again)
    umount: forced umount of (null) failed!

    initrd: umount failed on rootfs
    try to run coLinux without initrd. Comment out initrd from configuration.

    Press <ENTER> to continue
    ----------------------------------------------------------------------------

    on pressing enter the window closes.

    My configuration file is as follows:

    <?xml version="1.0" encoding="UTF-8"?>
    <colinux>
    <!-- This line needs to point to your root file system. 
    For example change "root_fs" to the name of the Debian image.
    Inside coLinux it will be /dev/cobd0 

    Block Device Aliasing: You can now handle most dual-boot issues
    by adding an alias="devname" to block_device. i.e. alias="hda",
    alias="hda1" You can do this for SCSI as well as IDE. You need
    to be aware that if you add an alias, you need to change your
    bootparams root="devname" appropriately (you may need to use
    devfs naming in some situations). -->
    <block_device index="0" path="\DosDevices\c:\coLinux\Debian-3.0r2.ext3-mit-backports.1gb" enabled="true" />

    <!-- This line can specify a swap file if you wish, or an additional
    image file, it will /dev/cobd1. Additional block_devices can
    be specified in the same manner by increasing the index -->

    <block_device index="1" path="\DosDevices\c:\coLinux\swap_device" enabled="true" />

    <!-- This is an experimental feature, it may not function completely.
    <cofs_device index="0" type="flat" path="\DosDevices\C:\&quot; enabled="true" />
    -->

    <!-- bootparams allows you to pass kernel boot parameters -->
    <bootparams>root=/dev/cobd0</bootparams>

    <!-- Initial RamDISK (initrd) support -->
    <initrd path="initrd.gz" />

    <!-- image allows you to specify the kernel to boot -->
    <image path="vmlinux" />

    <!-- this line allows you to specify the amount of memory available 
    to coLinux -->
    <memory size="64" />

    <!-- This allows you to modify networking parameters, see the README 
    or website or wiki for more information -->
    <network index="0" type="tap" />
    </colinux>

    I am using the Debian distribution and I have unzipped it twice (using bzip and winzip) as I was told it might be the file had got corrupted but the error happens with both versions.

    I have tried to comment out initrd but when I do I just get a blank screen.....I cannot see any other errors in the config file.

    Thanks for your help!

     
    • which version do you use?

      since version 0.6.2 the new config file format must be used!

      Bebbo