modules for 2.6.12-co-0.7.1

Help
kc57
2007-09-05
2013-05-09
  • kc57
    kc57
    2007-09-05

    upgrading to 0.7.1 requires seperately adding the new modules, following the instruction from the Wikia page:  The file initrd contains no modules. Modules are only in the file vmlinux-modules.tar.gz. The initrd extracts modules over device cofs31 automaticly, if you configure it as "initrd=initrd.gz" in config file. After modules are installed, you can remove the initrd from config.

    The install package places vmlinux-modules.tar (WinZip) file in the coLinux folder which is not correctly loaded by initrd, causing an error to occur in the root file system check and request to boot in single user mode.

    The modules are in the compressed file, how does one get it properly configured?

    Thanks

     
    • Henry N.
      Henry N.
      2007-09-11

      The installer saves the Modules as file vmlinux-modules.tar.gz in the same directory should exist the file initrd.gz

      In your config should add the line
        initrd=initrd.gz
      That's all. In the config should exists a line
        root=/dev/cobd0
      (replace with your rootfs device). With these parameter the modules would be installed automaticly.

      In cormal case initrd would install the modules again on next boot, until no modules for current kernel are installed in your rootfs.

      If the initrd dosn't work, you can do the steps self. These are the steps, what initrd does:

        mount -o ro -t cofs cofs31 /mnt
        tar xzf /mnt/vmlinux-modules.tar.gz -C /
        touch /linux/lib/modules/`uname -r`/modules.dep
        chown 0:0 -R /lib/modules/*-co-*

      From line 79 you can see the same contains inside initrd script:
      http://colinux.svn.sourceforge.net/viewvc/colinux/branches/stable/conf/initrd-linuxrc?view=markup