Hi All,

I tried installing codestriker on Linux System, but it is throwing error while running install.pl. Below is the error I'm getting. I tried codestriker 1.9.9 and 1.9.10, but on both versions I'm getting the error shown below. I downloaded codestriker  [both versions]from the link http://sourceforge.net/projects/codestriker/files/codestriker/1.9.10/
and followed the instruction from http://codestriker.sourceforge.net/c49.html.

[root@requests bin]# ./install.pl
String found where operator expected at /opt/codestriker/codestriker-1.9.9/lib/Codestriker.pm line 563, near "croak "Failed to execute $system_line: $!\n""
        (Do you need to predeclare croak?)
syntax error at /opt/codestriker/codestriker-1.9.9/lib/Codestriker.pm line 563, near "croak "Failed to execute $system_line: $!\n""
Compilation failed in require at /opt/codestriker/codestriker-1.9.9/lib/Codestriker/DB/DBI.pm line 14.
BEGIN failed--compilation aborted at /opt/codestriker/codestriker-1.9.9/lib/Codestriker/DB/DBI.pm line 14.
Compilation failed in require at /opt/codestriker/codestriker-1.9.9/lib/Codestriker/Model/User.pm line 14.
BEGIN failed--compilation aborted at /opt/codestriker/codestriker-1.9.9/lib/Codestriker/Model/User.pm line 14.
Compilation failed in require at ./install.pl line 58.
BEGIN failed--compilation aborted at ./install.pl line 58.

I'm using:
Enterprise RedHat 5.5, on 32 bit machine
DB: Mysql

Could you please help me in fixing this issue.

Thanks,
Jain Jacob