Found the problem:

 

The issue seems to be if you are using Subversion and have a “file name” as a module.

 

For example, start tag = 8, End tag = 10 module = trunk/wqs/ccacherec.cpp

 

This shows up in ScmBug extensions so much as this is what that code does behind the covers.

 

The issue is down to Subversion.pm function “is_file_url” not flagging files correctly.

 

The XML from the query is:

 

<?xml version="1.0"?>

<info>

<entry

   kind="file"

   path="ccdqpdef.cpp"

   revision="11">

<url>…………/svn/coderepo/trunk/wqs/ccdqpdef.cpp</url>

{snip}

</info>

 

The problem in this instance is the line:

 

                        $file_url = $1 eq "File";

Changing it to:

                        $file_url = $1 eq "file";

 

Solves the problem – or maybe make it case in-sensitive?

 

I’m really sorry for not picking this up before release of 1.9.5 – I shouldn’t have missed something like this.

 

Cheers


Rob

 

 

 

 


From: codestriker-user-bounces@lists.sourceforge.net [mailto:codestriker-user-bounces@lists.sourceforge.net] On Behalf Of Robert Hudson
Sent: 10 July 2008 15:30
To: codestriker-user@lists.sourceforge.net
Subject: Re: [Codestriker-user] Hanging on Parallel View

 

 

Update: Think this may actually be caused earlier in the process.  Just realised that the file name being used has the filename twice in the path:

 

trunk/wqs/ccacherec.cpp/ccacherec.cpp

 

This is what is also displayed on the ViewTopic page.

 

This was generated using the ScmBug support – so may be something that is only a problem via that root.

 

Cheers

 

Rob

 

 

 


From: codestriker-user-bounces@lists.sourceforge.net [mailto:codestriker-user-bounces@lists.sourceforge.net] On Behalf Of Robert Hudson
Sent: 10 July 2008 14:53
To: codestriker-user@lists.sourceforge.net
Subject: [Codestriker-user] Hanging on Parallel View

 

 

I’m hoping that some-one else has seen this and found an easy solution J

 

I am upgrading a lot of applications that get used with Codestriker and have found a problem that I don’t have on non upgraded systems.

 

Versions are as follows:

 

Codestriker 1.9.5

Subversion 1.5

Windows 2003

Apache 2.2

ActivePerl 5.10.0

  LWP::UserAgent (any)     ok: found v5.810

  CGI (v2.56)   ok: found v3.29

  Net::SMTP (any)     ok: found v2.31

  MIME::QuotedPrint (v2.14)   ok: found v3.07

  DBI (v1.13)   ok: found v1.604

  Template (v2.07)   ok: found v2.19

  HTML::Entities (any)     ok: found v1.35

  File::Temp (any)     ok: found v0.18

  XML::RSS (v1.05)   ok: found v1.31

  Encode::Byte (any)     ok: found v2.03

  Encode::Unicode (any)     ok: found v2.05

  DBD::mysql (any)     ok: found v4.005

  Win32::OLE (any)     ok: found v0.1709

  ScmBug::ActivityUtilities (any)     ok: found v0

 

Everything appears to be working OK with the exception of Parallel view of files.  When I select this it open the new window but then just remains busy and never loads the data.  There is no error data in the Apache log.

 

Any suggestions would be great.

 

Thanks

 

Rob