hi all,

I am using 1.9.9 version of codestriker. When iam trying to create new post mozilla giving error

Software error:

Command failed: Failed to execute "/usr/bin/svn" "cat" "--non-interactive" "--no-auth-cache" "--username" "balu.phani" "--password" "root123" "http://192.168.2.29/svn/svn_repos/fips_ssl/main/board/drivers/nitrox/linux_main.h@12" > "/tmp/ejatWeBuGz/stdout.txt" 2> "/tmp/ejatWeBuGz/stderr.txt": Inappropriate ioctl for device
at /svn/codestriker-1.9.9/lib/Codestriker/Repository/Subversion.pm line 145

/usr/bin/svn cat --non-interactive --no-auth-cache --username balu.phani --password root123 http://192.168.2.29/svn/svn_repos/fips_ssl/main/board/drivers/nitrox/linux_main.h@12
Check your webserver error log for more information.
at /svn/codestriker-1.9.9/lib/Codestriker/Repository/Subversion.pm line 145

For help, please send mail to the webmaster (root@localhost), giving this error message and the time and date of the error.

from command line  this command is executing.
"/usr/bin/svn" "cat" "--non-interactive" "--no-auth-cache" "--username" "balu.phani" "--password" "root123" "http://192.168.2.29/svn/svn_repos/fips_ssl/main/board/drivers/nitrox/linux_main.h@12"
my codestriker.conf is


$db = 'DBI:mysql:dbname=codestrikerdb';
$dbuser = 'codestriker';
$dbpasswd = 'cspasswd';
$mailhost = 'localhost';
$use_compression = 0;
$gzip = '/bin/gzip';
$cvs = '/usr/bin/cvs';
$svn = '/usr/bin/svn';
$ssh = '/usr/local/bin/ssh';
$p4 = '/usr/local/bin/p4';
$highlighter = '';
@valid_repositories =
    (
       'svn:http://192.168.2.29/svn/svn_repos;balu.phani;root123'
    );
$repository_name_map =
{
'svn:http://192.168.2.29/svn/svn_repos;balu.phani;root123' => 'SF SVN'
};

$file_viewer =
{
    '/home/sits/cvs' => 'http://localhost/cgi-bin/cvsweb.cgi',
    'svn:file:///var/svn/project/trunk' =>
        'http://some.whe.re/cgi-bin/viewvc.cgi/trunk/?root=Project&view=markup'
};

@exclude_file_types = ('rtf', 'doc', 'gif', 'bmp', 'jpeg', 'jpg', 'mdb',
                       'ppt', 'vsd', 'xls', 'zip', 'tgz', 'tar', 'gz',
                       'opt', 'aps', 'ncb', 'a', 'so', 'dll', 'lib',
                       'exe', 'png', 'pdf', 'bin', 'out', 'ld', 'fm',
                       'indd', 'wav', 'o', 'obj', 'mpp', 'vsw', 'jfif',
                       'tif', 'tiff', 'xbm', 'fnt', 'ttf', 'pfm', 'pfb',
                       'eps', 'wpj', 'sxi');

$maximum_topic_size_lines = '';
$suggested_topic_size_lines = '';
$NORMAL_MODE = 0;
$COLOURED_MODE = 1;
$COLOURED_MONO_MODE = 2;
$default_topic_create_mode = $COLOURED_MODE;
$default_file_to_view = 0;
@topic_states = ('Open', 'Closed', 'Committed', 'Obsoleted', 'Deleted');
@readonly_states = ('Closed', 'Committed', 'Obsoleted', 'Deleted');
$allow_searchlist = 1;
@project_states = ('Open');
$antispam_email = 0;
$email_send_options =
    {
      comments_sent_to_topic_author => 1,
    comments_sent_to_commenter => 0,
    topic_state_change_sent_to_reviewers => 0
    };

$default_tabwidth = 8;
$sort_diffs_by_filename = 1;
$bug_db = 'bugzilla';
$bug_db_host = 'localhost';
$bug_db_name = 'bugs';
$bug_db_password = 'abc_123';
$bug_db_dbname = 'bugs';
$bug_db_user_id = '2';
$bugtracker = '';
$bugtracker = 'http://localhost.localdomain/bugzilla/show_bug.cgi?id=';
$lxr_map =
{
};

$topic_text_encoding = 'utf8';
$comment_state_metrics =
    [
      { name             => 'Status',
        values           => ['Submitted', 'Invalid', 'Completed'],
        default_value    => 'Submitted',
        show_on_mainpage => ['Submitted' ]
      }
    ];
$metric_config = "all";

and in conf.d, subversion/conf i added required configuration lines for repositories and can be accessible through net.

so i don't understand why it is giving problem.

please help me