In Ubuntu precise (12.04 LTS) the package libdigest-sha1-perl has been renamed to libdigest-sha-perl