Clonezilla stucks after pressing arrows key on the first screen

2013-10-01
2014-03-06
  • I have installed Clonezilla SE on the latest ubuntu server release (13.04), everything seems to work correctly but when, after booting the client from PXE, I try to select an option with arrows keys on the first menu the wizard exits and go back to the ubuntu loading screen( purple background with 4 dots blinking) .

    The screen where it stucks is the first : Save or restore selection in my case.

    There is no way to restore or save the disk .

    The problem seems to be very similar to this one : sourceforge.net/p/clonezilla/discussion/Help/thread/d8f23d11/?page=0

    It seems a problem related to the keyboard.

    Someone have a solution or a workaround ?

     
  • Steven Shiau
    Steven Shiau
    2013-10-13

    If it's similar to
    sourceforge.net/p/clonezilla/discussion/Help/thread/d8f23d11/?page=0
    then we are still having problem to fix it. Since we can not produce the problem here, so it's very difficult to fix the issue.
    However, a workaround you could try:
    http://clonezilla.org/clonezilla-SE/use_clonezilla_live_in_drbl.php

    Steven.

     
  • Hi,
    I tried following the guide you posted but I can't find any workaround and the situation still the same, do you have any ideas ?

    I've tried adding the flag : keyboard-layouts=NONE to the append section but no luck ...

    How can I solve the problem ?

    Is the problem really related to the Keyboard layout ?

     
  • Steven Shiau
    Steven Shiau
    2013-10-30

    "I can't find any workaround and the situation still the same, do you have any ideas ? " -> So you are sure your DRBL client machines are using Clonezilla live to do the imaging and restoring jobs? Others have mentioned that by doing that, no keyboard issue.

    Steven.

     
  • If I use the the Live CD I have no problem ... But if I have installed the PXR server is because I need the server ...

    I even tried to configure testing repository and updating everythin but the situation still the same, even on the new Ubuntu Server 13.10 .

    Any ideas ?

     
  • If I use the the Live CD I have no problem ... But if I have installed the PXR server is because I need the server ...

    I even tried to configure testing repository and updating everythin but the situation still the same, even on the new Ubuntu Server 13.10 .

    Any ideas ?

     
  • Steven Shiau
    Steven Shiau
    2013-11-13

    I meant when you configuring DRBL server, during "drblpush -i":

    In the system, there are 4 modes available for clonezilla:
    [0] Full Clonezilla mode, every client has its own NFS based /etc and /var.
    [1] Clonezilla box mode, every client uses tmpfs based /etc and /var. In this mode, the loading and necessary disk space of server will be lighter than that in Full Clonezilla mode. Note! In Clonezilla box mode, the setting and config files of client will not be saved to the DRBL server! They just use once and will vanish after the machine shutdowns!
    [2] I do NOT want clonezilla.
    [3] Use Clonezilla live as the OS (Operating System) of clients (Testing).
    Which mode do you prefer?


    Did you choose [3]? If so, then your client machine will use Clonezilla live to do the clonezilla job. If you choose [1], it will use NFS-based file system for the "/" (root file system).

    Steven.

     
  • daffy
    daffy
    2014-02-20

    I am getting the same issue after I installed updates from Ubuntu 12.04 LTS. I have since reinstalled drbl and I did chose option 1 for box mode during drbpush -i but this problem persist. My system was running fine previously.

    Copy of my selection
    In the system, there are 4 modes available for clonezilla:
    [0] Full Clonezilla mode, every client has its own NFS based /etc and /var.
    [1] Clonezilla box mode, every client uses tmpfs based /etc and /var. In this mode, the loading and necessary disk space of server will be lighter than that in Full Clonezilla mode. Note! In Clonezilla box mode, the setting and config files of client will not be saved to the DRBL server! They just use once and will vanish after the machine shutdowns!
    [2] I do NOT want clonezilla.
    [3] Use Clonezilla live as the OS (Operating System) of clients (Testing).
    Which mode do you prefer?
    [0] 1

    Thanks

     
    Last edit: daffy 2014-02-20
  • daffy
    daffy
    2014-02-25

    Hi Steven

    Yes, I did uninstall and reinstall drbl per instructions. But problem still exist. Here is the drbl-bug-report from the server

    Thanks

    ==
    OS version: Ubuntu 12.04
    Server arch: x86_64
    Server CPU: Intel(R) Core(TM) i3 CPU 550 @ 3.20GHz
    Server memory size: 16423200 kB
    Server Kernel version: 3.2.0-30-generic
    Installed DRBL-related packages: drbl-2.6.15-drbl1 clonezilla-3.8.12-drbl1 mkswap-uuid-0.1.1-1drbl partclone-0.2.66.drbl1 drbl-chntpw-20110511-1drbl mkpxeinitrd-net-2.1.4-drbl1 ipxe-20131008-drbl1 freedos-1.0-19drbl partimage-0.6.8-2.2 ntfsprogs-1:2012.1.15AR.1-1ubuntu1.2 gzip-1.4-1ubuntu2 bzip2-1.0.6-1 lzop-1.03-3 pigz-2.1.6-1 pbzip2-1.1.6-1 udpcast-20120424-drbl2 syslinux-2:5.10+drbl-1
    Client kernel version: 3.2.0-30-generic
    Client kernel arch: x86_64
    NICs with private IP address in server: eth1 eth2
    Private IP address in server: 192.168.99.174 192.168.0.1
    Total client no: 12
    Client IP address: 192.168.0.2 192.168.0.3 192.168.0.4 192.168.0.5 192.168.0.6 192.168.0.7 192.168.0.8 192.168.0.9 192.168.0.10 192.168.0.11 192.168.0.12 192.168.0.13

     
    Last edit: daffy 2014-02-27
  • I have a workaround that may help you.

    Here

     
  • Steven Shiau
    Steven Shiau
    2014-03-06

    Today I uploaded a version to address this issue.
    Please give the version drbl (2.7.30-drbl1) in the unstable release a try.
    Let me know the results.
    Thanks.

    Steven.