Fetch fails after PXE Boot because of DHCP Timeout / static doesn't work

Jens Holze
2014-01-07
2014-01-20
  • Jens Holze
    Jens Holze
    2014-01-07

    Hi there!

    I've got a problem with booting clonezilla live via PXE. The initial part works but after the kernel ran it's messages and the network interfaces are activated the boot fails because it seems that our dhcp server takes longer than 15 seconds to answer the request (takes up to 30s sometimes for the first part, not sure why). Yet he does answer it, if I run 'ipconfig eth1' after it has failed the interfaces seems to have the ip.
    is there a way to extend the timeout to more than 15 seconds? There are two interfaces yet only one is connected. I'm using version 2.2.0-16.

    Also, I tried to configure the network with a static ip by adding the ip option in the pxelinux.cfg but that seems to be ignored. It reads

    APPEND initrd=clonezilla/initrd.img boot=live live-config noswap nolocales edd=on nomodeset ocs_live_run="ocs-live-general" ocs_live_extra_param="" ocs_live_keymap="/usr/share/keymaps/i386/qwertz/de-latin1-nodeadkeys.kmap.gz" ocs_live_batch="no" ocs_lang="en_US.UTF-8" ocs_daemonon="ssh" vga=788 nosplash  ip=eth1:xxx.xxx.xxx.xxx:255.255.255.0:yyy.yyy.yyy.yyy fetch=http://yyy.yyy.yyy.yyy/ubuntu10_4/clonezilla/live/filesystem.squashfs
    

    yet DHCP timeout still occurs.

    Any help would be appreciated, thanks.

     
  • Steven Shiau
    Steven Shiau
    2014-01-12

    From what you have posted, the issue is before the linux kernel and initra are loaded. Therefore the boot parameters you have assigned won't work. They will work only when Linux kernel and system start booting.
    If you can not tune the network switch or DHCP service, then PXE won't work I think. You might need to use USB stick or CD to boot Clonezilla live.

    Steven.

     
  • Johannes
    Johannes
    2014-01-20

    I have a similar problem, ip= is just ignored. And since I don't have my tftp server connected to eth0 (it's on eth1) boot fails and you drop into an (initramfs) prompt.

    clonezilla:/tftpboot # cat clonezilla/Clonezilla-Live-Version
    clonezilla-live-2.2.1-25-amd64
    This Clonezilla live zip file was created by this command:
    ocs-live-dev -c -s --extra-boot-param quiet -y 6.03-pre1 -i 2.2.1-25-amd64
    

    How do you configure clonezilla to use a different interface than eth0?

    EDIT:
    Nevermind I went through the boot files in initrd.img:/lib/live/boot/ and found some interesting parameters you can add in pxelinux.cfg/default: live-netdev=eth0 ethdevice-timeout=

     
    Last edit: Johannes 2014-01-31
  • Alex
    Alex
    2014-01-20

    If you're booting through a fancy switch that supports Spanning Tree Protocol, that will slow down DHCP immensely. Try to configure the route back to your server to use the 'Portfast' option to speed it up. Symantec has a good rundown of what's going on here:

    http://www.symantec.com/business/support/index?page=content&id=HOWTO6019