#182 Choose option -K1 (partition...) grow my Swap partition

open
Steven Shiau
None
5
2014-09-09
2013-07-10
Fabien Voland
No

Hello,

Today, I made an installation of Linux Mint on a HD 40 GB.

My partitions are composed as follows:

sda1 8 GB Swap
sda2 32 GB / ext4

I wanted to choose the option -K1 because I restored a 500 GB HD.

Unfortunately, the proportional change the partition size does not work well because I found myself with a swap 100 GB.

Normally, the creation of a table of proportional partition is the last partition expand to a larger HD. right?

For example, I made a backup of Win 7 system with 100 MB (system partition) and everything else partition. During the restoration, I
choose the option -K1 and then resize the last partition and has not touched the first partition Win 7 system of 100 MB.

A bug with the swap ?

Thank you in advance for your support.

Fabien

Discussion

  • Fabien Voland
    Fabien Voland
    2013-07-14

    Hi Steven,

    Excuse me, you're already aware. I just saw in the discussions.

    On the schematics, I'll let them, because it amazes me that I can bring something new.

    But on the swap, even choosing-k1, it is still the same amount of the old image or it is alone calculates the new size according to RAM.

    Bye!

    Fabien

     
  • Steven Shiau
    Steven Shiau
    2013-07-27

    Thanks for the reminder. Yes, I noticed this issue. However, too many functions to be improved. If you could have a patch file about this (the file to be modified is actually ocs-expand-mbr-pt), for sure it will be faster to improve.

    Steven.

     
  • Steven Shiau
    Steven Shiau
    2013-08-15

    Clonezilla live 2.1.2-40 is ready for this. Please confirm.
    Thanks.

    Steven.

     
  • Fabien Voland
    Fabien Voland
    2013-08-16

    Hi Steven,

    Thank you for the corrections.

    I was traveling the last few days but on Monday, I will test at my work.

    Again thank you.

    Fabien

     
  • Fabien Voland
    Fabien Voland
    2013-08-19

    Hi Steven,

    I wanted to try the latest test version on a HP dc7800 but unfortunately after selecting samba server, an error message appears and you can not see the dialogs. On a Dell OPT760 no problem but I did not test with the restoration partition resize.

    So I expect you to come out a new, more stable version.

    Do you need the error message ?

    Thank you.

    Fabien

     
  • Steven Shiau
    Steven Shiau
    2013-08-20

    "an error message appears and you can not see the dialogs. " -> What were the error messages? Or is it just a kernel message, not really an error and you still can go on?

    Steven.

     
    • Fabien Voland
      Fabien Voland
      2013-08-23

      Hi,

      Sorry for the delay. I have two jobs and my first, I'm here on Monday morning and Friday morning.

      I tested several brands without problem. But on an HP dc7800, a kernel message:

      mei_me 0000:00:030: Reset: Connect / Disconnect Timeout

      mei_me Unexpected reset: Resetting DEV_State =
      Reset: Connect / Disconnect timeout.

      This message appears after selecting the keyboard. From the start, taking five seconds and the message appears.

      Thank you in advance.

      Fabien

       
      • Fabien Voland
        Fabien Voland
        2013-08-23

        I forgot. The partition is now calculated.

        Thanks:-)

        Fabien

         
  • Steven Shiau
    Steven Shiau
    2013-08-29

    "mei_me 0000:00:030: Reset: Connect / Disconnect Timeout

    mei_me Unexpected reset: Resetting DEV_State =
    Reset: Connect / Disconnect timeout.

    This message appears after selecting the keyboard. From the start, taking five seconds and the message appears." -> I believe it's Linux kernel related. A newer, updated kernel in the future might help.

    Steven.

     
  • Fabien Voland
    Fabien Voland
    2013-08-30

    Hi Steven,

    I'll try the latest version (2.1.2-43) on Monday and I'll say it again if the problem persists.

    Thank you.

    And I forgot to thank you for giving me mention in the changelog. Again thank you :-)

    Fabien

     
  • Steven Shiau
    Steven Shiau
    2013-09-02

    Yes, after your test, please post the results. We'd like to different people in different environment to confirm this.
    Thanks.

    Steven.

     
  • Fabien Voland
    Fabien Voland
    2013-09-02

    Hi Steven,

    I tested the latest version on different machines and the swap is calculated.

    But the message Kernel described previously a problem: indeed, it also appears on a Dell OPT755 and it keeps showing not once. And I can not go further than the DHCP discover by Samba. He seeks DHCP and displays the Kernel and can not go further. It can not get IP from DHCP.

    Thank you in advance for your support.

    Fabien

     
  • Steven Shiau
    Steven Shiau
    2013-09-12

    "seeks DHCP and displays the Kernel and can not go further. It can not get IP from DHCP." -> So is this kernel/hardware support issue?
    If so, how about giving Clonezilla live 20130909-saucy a try?

    Steven.

     
  • Fabien Voland
    Fabien Voland
    2013-09-15

    Hi Steven,

    I tried but the same message. Posted less frequently, 'I could go to the end of the dialog boxes. But if you do not know by heart, you will not see the dialogs. And this time, the DHCP worked well.

    Fabien

     
  • Fabien Voland
    Fabien Voland
    2013-09-20

    Hi Steven,

    I tested the version test 2.1.2-53, same result.

    But already this message appears during the boot process.

    Fabien

     
  • Steven Shiau
    Steven Shiau
    2013-10-01

    So by "same result" you meant it failed to enter Clonezilla main menu? Or?

    Steven.

     
    • Allen
      Allen
      2013-11-20

      I found this thread because I seem to have the same issue. Also an Optiplex755. The mei_me timeout message appears on all of the Clonezilla prompts after a short delay, overwriting the menus and making it very difficult to navigate. I used an older version to get my restore done.
      2.2.0-16 i486 Debian -- timeout errors
      2.2.0-16 i386 Ubuntu -- timeout errors
      1.2.5-17 i486 -- WORKS!

       
  • Steven Shiau
    Steven Shiau
    2013-11-22

    Did you try Clonezilla live 20131118-trusty?
    It comes with Linux kernel 3.12 so maybe the results are different.

    Steven.

     
    • Fabien Voland
      Fabien Voland
      2013-11-28

      Hi,

      I will try.

      Fabien

       
  • DMAC-TECH
    DMAC-TECH
    2013-12-04

    Hi I am receiving the same issue with a DC7800 I also tried Clonezilla live 20131118-trusty as per Steven's suggestion.

    I will try the suggestions here https://bbs.archlinux.org/viewtopic.php?id=168403 and report back.

     
    Last edit: DMAC-TECH 2013-12-04
  • DMAC-TECH
    DMAC-TECH
    2013-12-04

    I tried blacklisting the mei module and that didnt work but I disabled the IMEI in the bios and I don't get the errors anymore.

     
  • Steven Shiau
    Steven Shiau
    2013-12-14

    So you meant after you disabled the IMEI, everything works?

    Steven.

     
  • I am getting the same errors over and over
    mei_me 0000:00:03.0: reset: connect/disconnect timeout

    It is related to the Intel Management Engine Interface. I would rather not disable this in BIOS. Does the newest release (with the newest kernel) fix this?

    Here is another thread that talks about this problem
    https://bbs.archlinux.org/viewtopic.php?id=168403

     
  • Steven Shiau
    Steven Shiau
    2014-03-06

    "Does the newest release (with the newest kernel) fix this?" -> Maybe. Did you give that a try? E.g. Clonezilla live 2.2.2-18 or 20140303-*?

    Steven.