Welcome to Fx2Ant

  • Welcome to Fx2Ant

    • Hi,

      I really wonder to use Fx2Ant, but I can't figure how to configure it to have it working. There were on little bug in the default urls to xsl files under Window > Preferences > Farata > Fx2ant : the / was ommited before home. Now that I have valid path to theses files, Fx2Ant still generate an invalid build file :

      <?xml version="1.0" encoding="UTF-8" standalone="no"?><FlexMetadata><actionScriptProperties mainApplicationPath="Index.mxml" version="3">
        <compiler additionalCompilerArguments="-locale en_US" copyDependentFiles="true" enableModuleDebug="true" generateAccessible="false" htmlExpressInstall="true" htmlGenerate="true" htmlHistoryManagement="true" htmlPlayerVersion="9.0.28" htmlPlayerVersionCheck="true" outputFolderPath="bin" sourceFolderPath="src" strict="true" useApolloConfig="false" verifyDigests="true" warn="true">
          <libraryPath defaultLinkType="1">
            <libraryPathEntry kind="4" path="">
                <libraryPathEntry kind="3" linkType="2" path="${PROJECT_FRAMEWORKS}/libs/player/{targetPlayerMajorVersion}/playerglobal.swc" useDefaultLinkType="false"/>
            <libraryPathEntry kind="1" linkType="1" path="libs"/>
            <libraryPathEntry kind="3" linkType="1" path="${PROJECT_FRAMEWORKS}/libs/player/9/playerglobal.swc" useDefaultLinkType="false"/>
            <libraryPathEntry kind="3" linkType="1" path="/home/kabnot/lib/flex/flexunit/0_9/bin/FlexUnit.swc" useDefaultLinkType="false"/>
            <libraryPathEntry kind="3" linkType="1" path="/home/kabnot/lib/eclipse/plugins/com.farata.logger_1.0.0.v200711072040/export/Log4Flex.swc" useDefaultLinkType="false"/>
          <application path="Index.mxml"/>
      <flexProperties flexServerType="0" toolCompile="true" useServerFlexSDK="false" version="1"/>

      Here my eclipse and plugins versions :

      Version: 3.3.2
      Build id: M20080221-1800

      Fx2Ant, Core, Core UI, Activator 1.0.0.v2007110

      Thanks for any help.

      • Hello,

        Under normal circumstances, Flex2Ant extracts all Flex project settings into  metadata XML file and then generates build properties' files and scripts using XSL stylesheets.

        Please notice flex2ant-build.xml. That is a build file.
        The XML content you have pasted into the message belongs to flex2any-master.xml, the metadata file extracted from the Flex project settings.

        Kind Regards,

    • Hi Victor and thank you for answering.

      The XML content I've pasted effectively belongs to a file named flex2ant-master.xml, but I'm still unable to locate a flex2ant-build.xml. fx2ant generate two file in my project :


      Is there any action to do for generating the flex2ant-build.xml file ?


      • May I miss something?

    • Anupam Shah
      Anupam Shah

      Hi Victor,

      I also facing the same problem mentioned by Stephane. There is no build file generated only master and properties file.


    • Anupam,

      Just re-installed Ganymede, FBPlugin 3.3, latest Farata from SF and can not reproduce the problem.
      That said I am running

      JAVA_HOME is pointing to ...\Program Files\Java\jdk1.6.0_07
      PATH contants ...\Program Files\Java\jdk1.6.0_07\bin

      Eclipse Window Preferences\Java\InstalledJRE points to same as JAVA_HOME

      What is your environment?

      Finally, please lookup and send relevant information from Window/ShowView/ErrorLog.


      Kind Regards,

    • Anupam Shah
      Anupam Shah

      Hello Victor,

      Thanks for replying.

      I got the problem solved, I was installing the Fx2ANT plugin from http://mantis.faratasystems.com/downloads/update/site.xml
      I think I was getting the older version of the plugin.
      I am able to generate the build file with the plug-in downloaded from SF and adding a local site in Help->Software Updates.

      One more thing whenever I generate the ant file, it is also generating file with the extension "clearbi".
      Is it expected behaviour?

      Thanks for the wonderful plugin.


  • elsouza

    Hi guys

    i was trying to use the Flex2Ant with Vista and FlexBuilder 3 but it's a little bit weird and i was hopping you could help me out here.

    I've realized that i was making the same mistake that anupam11, so, when i downloaded and installed the newer version, like Anupam did, the menu "Flex2Ant->Generate build file" it's not being shown.

    The licence menu appears on Windows preferences and i put my license without problems

    i've restarted the Flex Builder maaany times, what else can i do?!