#572 new check: SimpleAccesorNameNotationCheck

Future
closed
nobody
Check (274)
5
2013-11-17
2011-05-08
Roman Ivanov
No

All developers know that is better to name geter and setter due to Java bean notation. But ... this is always happen that somebody missed this or after refactoring get/set method are missed from renaming. Special check will be usefull here:

Check only direct fields and setter and getter. We can't be extremely smart to cover all case. But simple templates that a presented below we need to check (opt).
XXXType getXXXName() {return XXXName}
XXXType getXXXName() {return this.XXXName}
void setXXXName(XXXType value) { this.XXXName = value}
void setXXXName(XXXType value) { XXXName = value}
Options:
- member prefix "m_"

Discussion

  • Ivan Sopov
    Ivan Sopov
    2013-11-17

    SimpleAccessorNameNotationCheck - implemented in sevntu.checkstyle sandbox project and maybe will be move to the main project.

     
  • Ivan Sopov
    Ivan Sopov
    2013-11-17

    • status: open --> closed
    • Group: --> Future