Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#73 Misleading doc for checkUnusedThrows

release_3.0
closed
Lars Kühne
5
2012-10-10
2002-12-05
Daniel Cox
No

The following from the config_javadoc.html page is
misleading:

"The property checkstyle.javadoc.checkUnusedThrows
controls whether to check if an undocumented
exception is a subclass of java.lang.RuntimeException.
The property type is boolean and defaults to false."

This should really read:

"The property checkstyle.javadoc.checkUnusedThrows
controls whether to ignore documented exceptions that
are not declared if they are a subclass of
java.lang.RuntimeException. The property type is
boolean and defaults to false.

The check itself could have a more meaningful name,
but I am at a loss to find a short one.
ignoreUndeclaredRuntimeThrows seems a little long.

Discussion

  • Lars Kühne
    Lars Kühne
    2002-12-27

    Logged In: YES
    user_id=401384

    the documentation has been fixed in CVS, thanks for
    reporting this problem.

    the property has been renamed to allowUndeclaredRTE, hope
    the name is more adequate.

     
  • Logged In: NO

    Yes - definitely a better name. Keep up the good work guys.
    I am looking forward to 3.0!