When constructing the setter method name the JavaBeans naming convention is not used thus resulting in a Hidden Field warning for a setter methods.
For example for a field with the name xAxis a setter with the name setxAxis is correct but the HiddenFieldCheck isIgnoreSetterParam method constructs the setter name to check by always capitalizing the first letter of the field which produces the wrong method name setXAxis. According to point 8.8 of the JavaBean 1.01 spec if the first two letters of the name are upper case the name is returned as is. In this case the name of the field would become XAxis not xAxis.
HiddenFieldCheck isIgnoreSetterParam setter method name construction should be updated to match the JavaBeans specification.