#230 JUnitTestCase erroneously mention tearDown instead of setUp.

release_3.5
closed
Rick Giles
Tests (17)
5
2012-10-10
2004-05-18
Paul Guyot
No

One can have the following error message:

../../com/kallisys/sma/simulacion/app/GameApplication.java:128:5:
The method 'setup' should be named 'setUp'.
../../com/kallisys/sma/simulacion/app/GameApplication.java:128:5:
The method 'tearDown' must be declared with no parameters.

while there is no tearDown method.

The attached patch fixes the bug.

Discussion

  • Paul Guyot
    Paul Guyot
    2004-05-18

    Patch to fix the bug

     
    Attachments
  • Rick Giles
    Rick Giles
    2004-05-19

    Logged In: YES
    user_id=539926

    Thank you for the patch. Corrected in 3.5 CVS.