#31 list() causes segfault

closed-duplicate
nobody
None
5
2011-04-25
2011-04-25
Anonymous
No

Similar to a previous problem, calling "list()" with cgtypes objects (like vec3) defined by cgkit cause segfaults. E.g.

>>> v = vec3()
>>> list(v)
Segmentation Fault

I've tried it on Ubuntu 10.4 AND Ubuntu 9.10, with boost 1.40 and 1.46. (both the ubuntu standard boost pacakge and one that was hand-built.

Discussion

  • Matthias Baas
    Matthias Baas
    2011-04-25

    • status: open --> closed-duplicate
     
  • Matthias Baas
    Matthias Baas
    2011-04-25

    Looks like this is a duplicate. See bug 2935729. I have closed this one, if you want to add a comment, add it to that other bug report (one thing your report is missing is how you imported the cgtypes module, was it via cgkit.all or directly from cgkit.cgtypes?)
    Anyway, this is a known issue with Ubuntu. I have never been able to reproduce this on either OSX, Windows or Fedora and I have never heard of anybody having the same problem on any other Linux distribution. As I can't reproduce this, there's little I can do to investigate it. So unfortunately, this has to wait until someone steps up who is running Ubuntu, who knows how to debug such problems and who is willing to spend some time investigating this. Sorry, it just seems there's a fundamental difference between Ubuntu and other Linux distributions.