Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Problem displaying tooltips in Firefox 2.0

Help
2007-05-04
2013-01-13
  • Kristy Anstett
    Kristy Anstett
    2007-05-04

    Hi all,

    I am having problems displaying chart tooltips in Firefox 2.0. Tooltips work fine in IE 6 and 7. I recently upgraded from CeWolf 0.9.8 to 1.0. (Tooltips didn't work using either version.)

    I have already searched this forum, and as recommended, I copied overlib.js into the /etc directory of my webapp. This didn't fix the problem.

    Here is some example code:

    UserRatingsReport.java:

    public String generateToolTip(CategoryDataset dataset, int series, int item) {

            String toolTip = new String();
            toolTip += "# of Questions: "
                    + String.valueOf(dataset.getValue(series, item)) + "\n";
            toolTip += "% of Total: "
                    + getPercentage(dataset.getValue(series, item).intValue(),
                            totalNumRatedQuestions) + "%";
            return toolTip;

        }

    urrDisplay.jsp:

    <cewolf:chart
        id="chart2"
        type="verticalbar" 
        xaxislabel="<%=xAxisLabel%>"
        yaxislabel="<%=yAxisLabel%>"
        howlegend="false">
        <cewolf:data>
            <cewolf:producer id="urReport">
                  <cewolf:param name="<%=UserRatingsReport.START_DATE_PARAM%>" value='<%=startDate.getTime() + ""%>'/>
                  <cewolf:param name="<%=UserRatingsReport.END_DATE_PARAM%>" value='<%=endDate.getTime() + ""%>'/>                   
                  <cewolf:param name="<%=UserRatingsReport.INTERFACE_ID_PARAM%>" value='<%=interfaceID + ""%>'/>           
            </cewolf:producer>
        </cewolf:data>
        <cewolf:chartpostprocessor id="urReport"/> 
    </cewolf:chart>
    <cewolf:img chartid="chart2" renderer="/cewolf" width="<%=width%>" height="<%=height%>" border="0">   
        <cewolf:map tooltipgeneratorid="urReport" linkgeneratorid="urReport" />   
    </cewolf:img>

    Can anyone think of anything I'm missing to get this working??

    Thanks!