Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo


Is project Celestia still active?

dimi dpa
  • dimi dpa
    dimi dpa

    Is Celestia still active?
    does updated?

    • JJBedoya

      The Celestia motherlode is still somewhat active. It's where they have all the add-ons for Celestia.


      Last edit: JJBedoya 2014-07-31
  • ross613

    Not very, looks like. But there is a 1.7 version (unfinished) in the code area that looks like the next release under development. A pity furtherance of this project has been stagnant for 5+ years now....so much potential!


    • Is there any chance of the current 1.7 version getting a release? If not, what's holding it back?

  • Dear Improvers,

    first of all, please, let me introduce myself and tell you the topic of my letter.
    I am Bertalan Peter Farkas, an ICT Methodology Consultant at EDUCATIO Public Services Nonprofit LLC in Hungary. Educatio is a non-profit educational background institution of the Hungarian Ministry of Human Resources which plays a key role in disseminating the use of ICT among the participants of public education.

    Our institution has a R&D project connected to open resources in public education. In this project we will try open operation systems and STEM (science, technology, engineering and maths) softwares in classrooms. In last few weeks we tried to identify appropiate softwares and applications and we found a software powered by you called Celestia that we plan to use in classrooms.

    For using of this application we would like to translate it to Hungarian. We have some key questions connected to translations.
    First of all, do you permit the translation of Celestia?
    Second, is there any language file among code files which we
    can use to translate easily?
    Third, if there is not language file(s), could you help us to identify the appropiate codes which we have to convert during translation.

    Please, contact us via email by the following address:
    Farkas Bertalan Péter: bertalanp.farkas_ at _gmail.com

    Thank you very much for your answering!

    Best regards
    Bertalan Peter Farkas

  • James Connolly
    James Connolly

    Hi all, I see this isn't completely comatose here.
    I've tried the forum on the Motherlode: it's a broken link which I've reported.

    I have a problem if anyone is listening: DDS files stopped working some time ago.
    I recently got around to reinstalling from scratch and removing all additions I'd added over the years: Now I'm trying to rebuild good planetary textures, and can only get JPG and so on to work.

    DDS files leave most of the surface blank, leaving only a narrow segment: There's some incompatibility, though as I said I've reinstalled from scratch.

    Any ideas anyone?

  • I'm close to suggesting that if the pre-1.7 version in the repo builds, let's release it :-P