#139 yellow glare fills screen

v1.5
closed-fixed
Toti
Core (65)
5
2008-01-02
2007-12-12
Selden Ball
No

Problem:
Celestia's window fills with a translucent yellow "glare" when the viewpoint is between about 7 and 70 au from the Sun.

This effect is seen when all of the following are true:
rendering of Orbit paths is selected
using Render paths Basic or Multitexture
using a Lua ScriptedOrbit function
running Celestia v1.5.0pre4 or built from cvs today.

This effect is *not* seen when any one of the following is true:
orbit rendering is not selected
in render paths which use vertex shaders
no lua ScriptedOrbit functions are used
running Celestia v1.5.0pre3

An addon demonstrating this problem is available at
http://www.lepp.cornell.edu/~seb/celestia/files/full-screen-glare.zip
(5KB)

Discussion

  • Toti
    Toti
    2007-12-14

    Logged In: YES
    user_id=1387492
    Originator: NO

    I cannot reproduce this bug at all.

     
  • Selden Ball
    Selden Ball
    2007-12-14

    Logged In: YES
    user_id=662401
    Originator: YES

    I just now verified that it still happens on my system.
    I did the following:
    + updated the video drivers to ForceWare v163.75
    + downloaded the Addon from the Web server.
    + Deleted the celestia/src/ directory, downloaded from SourceForge and built Celestia from scratch,
    + ran the newly built exe
    + selected the Addon's URL
    - Celestia started with Render Path OpenGL 2.0 and showed the solar system's orbits against a black background
    + typed a Ctrl-V to switch to Basic render path
    + Celestia immediately showed a translucent yellow background

    System config:
    1GB 3.4GHz P4-550, WinXP Pro SP2 with last night's patches
    256MB GF 7800 GTX, ForceWare v163.75
    Celestia from cvs built with Visual Studio 2005 Express

    s.

     
  • Selden Ball
    Selden Ball
    2007-12-14

    Logged In: YES
    user_id=662401
    Originator: YES

    another addendum:
    Render/View Options/show Orbit/spacecraft also must be enabled in order to see this.
    This flag is *not* included in a Celestia URL and must be selected manually.

     
  • Toti
    Toti
    2007-12-15

    Logged In: YES
    user_id=1387492
    Originator: NO

    Yes, that was it. I can now see the yellow glare with spacecraft orbit rendering turned on.

    Your addon defines an orbit bounding radius of 5*10^18. With the new depth buffer partitioning code for orbit rendering, the ratio between nearPlaneDistance and farPlaneDistance (from your cel::url POV) gets 9 orders of magnitude larger when orbits are activated and thus the halo size in renderBodyAsParticle() gets too big. Clamping this value to a reasonable maximum solves the yellow glare problem, but not the jump in halo size that happens when orbit rendering is toggled.

    For the record, the bug was fired up by the change at line 7675 in StarRenderer::process() in revision 1.281, Thu Oct 11 00:32:04 2007 UTC of render.cpp.

     
  • ElChristou
    ElChristou
    2007-12-22

    Logged In: YES
    user_id=1384920
    Originator: NO

    On today build on osX I can trigger the giant glare On/Off to a second even bigger glare by enabling or not spacecraft orbits. Others orbits don't trigger the second (and bigger) giant glare... (note that the second state disappear abruptly at ~88 au from the Sun)

     
  • ElChristou
    ElChristou
    2007-12-23

    Logged In: YES
    user_id=1384920
    Originator: NO

    if Toti's patch is approved (need test on Windows (and Linux?)) this bug/feature could be closed

     
  • Chris Laurel
    Chris Laurel
    2008-01-02

    Logged In: YES
    user_id=159994
    Originator: NO

    Has anyone seen this bug since Toti's change was checked in? If not, it should be marked fixed and closed.

     
  • Chris Laurel
    Chris Laurel
    2008-01-02

    • labels: 602284 --> Core
    • assigned_to: nobody --> toti1258
     
  • Selden Ball
    Selden Ball
    2008-01-02

    Logged In: YES
    user_id=662401
    Originator: YES

    I haven't.

    Closed as fixed.
    (Sorry, I thought I had.)

     
  • Selden Ball
    Selden Ball
    2008-01-02

    • status: open --> closed-fixed