Hello,

 

I’m using an older emacs, 21.1.4, but I think Cedet to compile and load correctly (v1.0 pre7).  I have the following statements in my .emacs file:

 

(load-file "~/elisp/cedet-1.0pre7/common/cedet.el")

(global-ede-mode 1)

(semantic-load-enable-gaudy-code-helpers)

(require 'semantic-ia)

 

When I invoke emacs with: emacs --debug-init, I get:

Debugger entered--Lisp error: (wrong-number-of-arguments #<subr defalias> 3)

  (defalias (quote semantic-ia-get-completions) (quote semantic-ia-get-completions-deprecated) "`Semantic-ia-get-completions' is obsolete.\nUse `semantic-analyze-possible-completions' instead.")

  require(semantic-ia)

  eval-buffer(#<buffer  *load*> nil "~/.emacs" nil t)

#### more stuff below here ####

 

Anybody ever seen this error before?