I'm at a loss then. I just tried make clean all, and also tried the May 14 snapshot. Perhaps there is something on the Mac that I'm unaware of.


On Mon, Jun 24, 2013 at 5:22 PM, Eric M. Ludlam <eric@siege-engine.com> wrote:
Hi Jai,

  The only thing I can guess is that if you had some old eieio files somewhere intruding on the build.  eieio was refactored recently to get rid of eval-and-compile statements, so if you are rebuilding-in-place, you might need a "make clean-all" first.

  You mentioned a June 3 snapshot though, so perhaps this is not the case?  Building the clean-all target might still help, but I'm not sure.

Good Luck

On 06/23/2013 10:58 PM, Jai Dayal wrote:
Hi All,

  Thanks for CEDET. It's great and I rely on it extensively on my linux
machines. I'm trying to install the June 3 snapshot, but when I make in
cedet, I get this error

find . -name "Makefile" -exec touch '{}' \;
make -C lisp
make -C speedbar
make[2]: Nothing to be done for `all'.
make -C eieio
/usr/bin/emacs -batch --no-site-file --eval '(setq debug-on-error t)' -l
"../../cedet-remove-builtin.el" -L ../cedet/ -L ./ --eval '(progn
(require (quote cedet-compat)))' -f batch-byte-compile eieio.el

In toplevel form:
eieio.el:57:1:Error: Symbol's value as variable is void: slot-unbound
make[2]: *** [eieio.elc] Error 1
make[1]: *** [eieio] Error 2
make: *** [compile] Error 2

I have also tried

make EMACS=/usr/bin/emacs

(which is what is returned when I type "which emacs")

Emacs version is: 24.3.1

What am I missing?


This SF.net email is sponsored by Windows:

Build for Windows Store.


cedet-semantic mailing list