When I look around, I see cedet 1.0, 1.0pre3 and 1.0beta7.  What is the compatibility of these versions? 

beta7 is installed at work, and it might be difficult to get it upgraded.  I have code that works with pre3, but appears to not work with beta7.  Is there a good way to get it to work with everything, or should I just try to get cedet upgraded?

Troy