What is the state of C++11 syntax support? Specifically I would like to stop having to write S<T<U> > with that extra space there. Is there a flag I can change or something?

On 2013-06-02 9:48 PM, <cedet-semantic-request@lists.sourceforge.net> wrote:
Send cedet-semantic mailing list submissions to
        cedet-semantic@lists.sourceforge.net

To subscribe or unsubscribe via the World Wide Web, visit
        https://lists.sourceforge.net/lists/listinfo/cedet-semantic
or, via email, send a message with subject or body 'help' to
        cedet-semantic-request@lists.sourceforge.net

You can reach the person managing the list at
        cedet-semantic-owner@lists.sourceforge.net

When replying, please edit your Subject line so it is more specific
than "Re: Contents of cedet-semantic digest..."


Today's Topics:

   1. Php support for newer CEDET (?????? ???????)
   2. semantic-displayor-point-position: consider       toolbar width
      (Pete Beardmore)
   3. help with 'semantic' setup (Canellas)
   4. 'semantic' error (Canellas)


----------------------------------------------------------------------

Message: 1
Date: Tue, 28 May 2013 23:34:11 +0300
From: ?????? ???????  <zargener@gmail.com>
Subject: [cedet-semantic] Php support for newer CEDET
To: cedet-semantic@lists.sourceforge.net
Message-ID: <51A514C3.2080902@gmail.com>
Content-Type: text/plain; charset=UTF-8; format=flowed

Hello, all.

It seems I've succeeded with fixing old PHP support for newer versions
of CEDET. It can be found here https://github.com/zargener/semantic-php .

But one thing is still workarounded - generation of variables:

wisent-php-wy--<number>-regexp-analyzer
wisent-php-wy--<string>-sexp-analyzer
wisent-php-wy--<keyword>-keyword-analyzer
wisent-php-wy--<symbol>-regexp-analyzer
wisent-php-wy--<punctuation>-string-analyzer
wisent-php-wy--<block>-block-analyzer

You can open php.wy at line 831 and try to make more beautiful solution.





------------------------------

Message: 2
Date: Wed, 29 May 2013 13:43:58 +0100
From: Pete Beardmore <elbeardmorez@msn.com>
Subject: [cedet-semantic] semantic-displayor-point-position: consider
        toolbar width
To: cedet-semantic@lists.sourceforge.net
Message-ID: <BLU0-SMTP1454806078596A2E91AE621D3900@phx.gbl>
Content-Type: text/plain; charset="utf-8"


hi,

having the x/gtk toolbar on the left causes completion tooltips to
cover the point/completion word. cue the attached for your consideration

cheers,
Pete

ps. the diff is larger than it really should be but i felt compelled
to change (fix?) the (pre-existing) mix of tabs/spacing in the rest of
the function. note there are a lot of functions like this :(
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001.semantic-displayor-point-position_.consider.toolbar.width.diff
Type: text/x-patch
Size: 1646 bytes
Desc: not available

------------------------------

Message: 3
Date: Sun, 2 Jun 2013 15:27:58 -0300
From: Canellas <rodrigo.canellas@gmail.com>
Subject: [cedet-semantic] help with 'semantic' setup
To: cedet-semantic@lists.sourceforge.net
Message-ID:
        <CABUv-0ekDpcyLXe=CZTX1d-1U6zncBCR4JG8zcm47sr4n=uL4Q@mail.gmail.com>
Content-Type: text/plain; charset="iso-8859-1"

Hi,

I followed the instructions found at
http://alexott.net/en/writings/emacs-devenv/EmacsCedet.html#sec4, at
http://www.emacswiki.org/emacs/CEDET_Quickstart and at
cedet.sourceforge.net/setup.shtml, but I just can't get 'semantic' to work.

This is what I did:

1 - I downloaded cedet_snapshot-rev_8563.tar.gz from
http://www.randomsample.de/cedet-snapshots/

2 - Then I did 'make clean-all && make'

3 - I moved the 'trunk' directory to 'cedet-bzr' inside '~/.emacs.d'

4 - In my '.emacs' file (of my 23.4.1 Emacs) I wrote:

(load-file "~/.emacs.d/cedet-bzr/cedet-devel-load.el")


(global-ede-mode 1)                      ; Enable the Project management
system
(semantic-load-enable-code-helpers)      ; Enable prototype help and smart
completion
(global-semantic-idle-completions-mode t)
(global-semantic-decoration-mode t)
(global-semantic-highlight-func-mode t)
(global-semantic-show-unmatched-syntax-mode t)

(semantic-mode t)

But when I try, for example, ' M-x semantic-complete-analyze-inline', I get
the error
"

Idle Work Typecaching Error: "#<buffer test1.cpp> - Wrong type argument:
stringp, (((0) \"ptrdiff_t\"))"

"


Can anyone point out what I'm doing wrong?


Thanks a lot!




    Rodrigo Canellas

    -----------
    Programador C++ <http://code.google.com/p/tenacitas/>
    Fot?grafo amador <http://photo.net/photos/RodrigoCanellas>
-------------- next part --------------
An HTML attachment was scrubbed...

------------------------------

Message: 4
Date: Sun, 2 Jun 2013 22:47:25 -0300
From: Canellas <rodrigo.canellas@gmail.com>
Subject: [cedet-semantic] 'semantic' error
To: cedet-semantic@lists.sourceforge.net
Message-ID:
        <CABUv-0ec-x+Xj_NUxwKZtw59h=o9kihCiHzQPsu-f1qDdF8wQA@mail.gmail.com>
Content-Type: text/plain; charset="iso-8859-1"

Hi,

I tried to use the '.emacs' posted by Alex Ott at
https://gist.github.com/alexott/3930120, which follows:

;;; minimial-cedet-config.el --- Working configuration for CEDET from bzr

;; Copyright (C) Alex Ott
;;
;; Author: Alex Ott <alexott@gmail.com>
;; Keywords: cedet, C++, Java
;; Requirements: CEDET from bzr (http://cedet.sourceforge.net/bzr-repo.shtml)

;; Do checkout of fresh CEDET, and use this config (don't forget to
change path below)

(setq cedet-root-path (file-name-as-directory "~/projects/cedet-bzr/"))

(load-file (concat cedet-root-path "cedet-devel-load.el"))
(add-to-list 'load-path (concat cedet-root-path "contrib"))

;; select which submodes we want to activate
(add-to-list 'semantic-default-submodes 'global-semantic-mru-bookmark-mode)
(add-to-list 'semantic-default-submodes 'global-semanticdb-minor-mode)
(add-to-list 'semantic-default-submodes 'global-semantic-idle-scheduler-mode)
(add-to-list 'semantic-default-submodes 'global-semantic-stickyfunc-mode)
(add-to-list 'semantic-default-submodes 'global-cedet-m3-minor-mode)
(add-to-list 'semantic-default-submodes 'global-semantic-highlight-func-mode)
(add-to-list 'semantic-default-submodes 'global-semanticdb-minor-mode)


;; Activate semantic
(semantic-mode 1)

;; load contrib library
(require 'eassist)

;; customisation of modes
(defun alexott/cedet-hook ()
  (local-set-key [(control return)] 'semantic-ia-complete-symbol-menu)
  (local-set-key "\C-c?" 'semantic-ia-complete-symbol)
  ;;
  (local-set-key "\C-c>" 'semantic-complete-analyze-inline)
  (local-set-key "\C-c=" 'semantic-decoration-include-visit)

  (local-set-key "\C-cj" 'semantic-ia-fast-jump)
  (local-set-key "\C-cq" 'semantic-ia-show-doc)
  (local-set-key "\C-cs" 'semantic-ia-show-summary)
  (local-set-key "\C-cp" 'semantic-analyze-proto-impl-toggle)
  )
(add-hook 'c-mode-common-hook 'alexott/cedet-hook)
(add-hook 'lisp-mode-hook 'alexott/cedet-hook)
(add-hook 'scheme-mode-hook 'alexott/cedet-hook)
(add-hook 'emacs-lisp-mode-hook 'alexott/cedet-hook)
(add-hook 'erlang-mode-hook 'alexott/cedet-hook)

(defun alexott/c-mode-cedet-hook ()
  (local-set-key "\C-ct" 'eassist-switch-h-cpp)
  (local-set-key "\C-xt" 'eassist-switch-h-cpp)
  (local-set-key "\C-ce" 'eassist-list-methods)
  (local-set-key "\C-c\C-r" 'semantic-symref)
  )
(add-hook 'c-mode-common-hook 'alexott/c-mode-cedet-hook)

(semanticdb-enable-gnu-global-databases 'c-mode t)
(semanticdb-enable-gnu-global-databases 'c++-mode t)

(when (cedet-ectag-version-check t)
  (semantic-load-enable-primary-ectags-support))


;; SRecode
(global-srecode-minor-mode 1)

;; EDE
(global-ede-mode 1)
(ede-enable-generic-projects)



;; Setup JAVA....
(require 'cedet-java)

;;; minimial-cedet-config.el ends here


I only changed

(setq cedet-root-path (file-name-as-directory "~/projects/cedet-bzr/")) to

(setq cedet-root-path (file-name-as-directory "~/.emacs.d/cedet-bzr/")), and

and commented the (require 'cedet-java) line.

The I wrote the following test program:

#include <fstream>
#include <iostream>
#include <utility>


class a {
public:
  void f(){}
};

int main (int argc, char * argv [])
{
  a a1;
  a1.
}

After typing "a1." a pressed 'ctrl+enter', and I got the message: "Wrong
type argument: stringp, (((0) "ptrdiff_t"))". I also tried to use the menu
as 'Development/Edit Tags/List Completions', or 'Development/Edit
Tags/Complete Tag Inline' with the same results.


Can anyone help me?



TIA!



   Rodrigo Canellas

    -----------
    Programador C++ <http://code.google.com/p/tenacitas/>
    Fot?grafo amador <http://photo.net/photos/RodrigoCanellas>
-------------- next part --------------
An HTML attachment was scrubbed...

------------------------------

------------------------------------------------------------------------------
Get 100% visibility into Java/.NET code with AppDynamics Lite
It's a free troubleshooting tool designed for production
Get down to code-level detail for bottlenecks, with <2% overhead.
Download for free and get started troubleshooting in minutes.
http://p.sf.net/sfu/appdyn_d2d_ap2

------------------------------

_______________________________________________
cedet-semantic mailing list
cedet-semantic@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/cedet-semantic


End of cedet-semantic Digest, Vol 83, Issue 1
*********************************************