Hi,
 
Downloaded the above beta release of cedet. I am on a Win2K box using Emacs 21.3.1. Followed the install instruction (I believe :-)) but when Emacs starts up I get the following error message in *Messages* buffer:
 
 
<snip>
Setting up speedbar...done
Setting up cedet-contrib...done
Loading semantic-decorate-mode...done
Loading senator...
 

An error has occurred while loading `c:/usr/local/.emacs':
 
error: "Package speedbar does not define speedbar-version"
 
To ensure normal operation, you should investigate the cause
of the error in your initialization file and remove it.  Start
Emacs with the `--debug-init' option to view a complete error
backtrace
Loading c:/usr/local/.session...done
Loading semantic-el...done
Loading lazy-lock...done
<snip>
 
 
Of course speedbar.el does in fact define speedbar-version, so I have no idea what is going on.
 
Here is the output of emacs --debug-init:
 
Debugger entered--Lisp error: (error "Package speedbar does not define speedbar-version")
  signal(error ("Package speedbar does not define speedbar-version"))
  error("Package %S does not define %S-version" speedbar speedbar)
  inversion-package-version(speedbar)
  inversion-test(speedbar "0.15beta1")
  inversion-require(speedbar "0.15beta1")
  byte-code("!,H@(B!,H@(B!,HD(B\",G"(B [require semantic semantic-util inversion inversion-require speedbar "0.15beta1"] 3)
  require(semantic-sb)
  byte-code("!,H@(B!,HC,_(B!,C
 
 
 
 
Thanks
Peter

Peter Milliken
Software Engineer
ResMed
Phone: +61 2 9886-5059
Fax:   +61 2 9878-5564