#69 ede crashes recent emacs CVS build

closed-fixed
ede (18)
5
2007-02-08
2005-05-28
Steven T. Hatton
No

If I have the following in my .emacs, when I open a file that is
under version control, emacs locks up, then crashes in about a
minute. The first line alone does not cause the problem. The
problem is from the second line.

(require 'ede)
(global-ede-mode t)

Discussion

  • Logged In: YES
    user_id=70886

    This happens when I am visiting files in the KDevelop svn
    repository image. I got a backtrace by quitting into debug
    before Emacs crashed. It looks to me as if EDE is going
    into a potientially infinite recursion and blowing up Emacs.
    See the attached file.

     
  • Logged In: YES
    user_id=70886

    This happens when I am visiting files in the KDevelop svn
    repository image. I got a backtrace by quitting into debug
    before Emacs crashed. It looks to me as if EDE is going
    into a potientially infinite recursion and blowing up Emacs.
    See the attached file.

     
  • Lisp backtrace of errant EDE execution

     
    Attachments
  • Eric M. Ludlam
    Eric M. Ludlam
    2005-06-21

    • assigned_to: nobody --> zappo
     
  • Eric M. Ludlam
    Eric M. Ludlam
    2007-02-08

    Logged In: YES
    user_id=88537
    Originator: NO

    Sorry for the long delay.

    I checked in a change today to prevent recursion (as indicated by your stack), but I wasn't
    able to replicate it to original problem to prove that I really did fix it. I expect you have "." as a path in your SUBDIRS automake variable, or something similar.

     
  • Eric M. Ludlam
    Eric M. Ludlam
    2007-02-08

    • status: open --> closed-fixed