Hi all,

Stephan and I needed a version JChemPaint working with 1.5.4. Thereís already a fair few forks of JChemPaint and Iím not really sure where the project stands but this was born out of necessity. Weíve stripped out the code and are building with maven. JChemPaint currently uses a NestedVM version of InChI (1.0.2) as the JNI code (InChI-API) canít be run as an applet. This version uses the CDK InChIGeneratorFactory / JNI-InChI and integrates better with our projects. This does mean you can not use it as an Applet, but Iím not sure how relevant applets are nowadays. 

We've deployed the build on the EBI repository: http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/ all dependencies should automatically resolve.

artifactId: jchempaint-hotfix
groupId:    org.openscience.jchempaint
version:    3.4

Source code: https://bitbucket.org/sbeisken/jchempaint-hotfix/src

Huge thanks to Stephan who has been keeping https://github.com/jchempaint/jchempaint patched up to the CDK master for use in Knime.

Thanks,
J