Okay,

You need to add 

<releases>
<enabled>false</enabled>
</releases>

to the snapshot repo. Iíll add that to the README. This could be something I mess up last year by deploying a release to snapshots by mistakes (I used to have perl scripts to do it :-)).

With that added, mvn dependency:analyze shows that is picks up the 1.5.5 release. Failing that also make sure youíre using Maven 3. Iím pretty sure the RELEASE also worked pre v 3. Also no harm in turning of snapshots from the release repo.

<repository>
            <id>ebi-repo</id>
            <url>http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/</url>
            <snapshots>
                <enabled>false</enabled>
            </snapshots>
        </repository>
        <repository>
            <id>ebi-repo-snapshots</id>
            <url>http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo-snapshots/</url>
            <releases>
                <enabled>false</enabled>
            </releases>
        </repository>

J