cclcfox can't find libcclcfox.so.0

Help
SeaBat
2007-10-10
2013-04-17
  • SeaBat
    SeaBat
    2007-10-10

    I'm running kubuntu on an AMD64.
    I'm trying to install client on Linux, first, and later the server in Windows.

    I've checked, and the libraries are in /usr/local/lib
      root@myhost:/home/uzer# ll /usr/local/lib/libccl*
      -rw-r--r-- 1 root root 74K 2007-10-08 17:49 /usr/local/lib/libcclc.a
      -rwxr-xr-x 1 root root 798 2007-10-08 17:49 /usr/local/lib/libcclc.la*
      lrwxrwxrwx 1 root root  16 2007-10-08 17:49 /usr/local/lib/libcclc.so -> libcclc.so.0.7.1*
      lrwxrwxrwx 1 root root  16 2007-10-08 17:49 /usr/local/lib/libcclc.so.0 -> libcclc.so.0.7.1*
      -rwxr-xr-x 1 root root 51K 2007-10-08 17:49 /usr/local/lib/libcclc.so.0.7.1*

    The /etc/ld.so.conf file reads :
      include /etc/ld.so.conf.d/*.conf

    The /etc/ld.so.conf.d/ directory contains :
       x86_64-linux-gnu
       Which contains :
          # Multiarch support
          /lib/x86_64-linux-gnu
          /usr/lib/x86_64-linux-gnu

    I added /etc/ld.so.conf.d/usrlibs
    Containing :
          /usr/lib
          /usr/local/lib

    But the test result is still :
      root@myhost:/home/uzer# cclcfox
      cclcfox: error while loading shared libraries: libcclc.so.0: cannot open shared object file: No such file or directory

    My fault, I guess, for suffering modernity.

    Any ideas on what could be going wrong ?

    Thanks.
     

     
    • gyuszicco
      gyuszicco
      2007-10-10

      You will find the missing files in /usr/local/lib and you have to make symlinks in /usr/lib. That worked for me.

       
    • SeaBat
      SeaBat
      2007-10-10

      Thank you.

      Ok. Much better.
      I'm running as su in a terminal window (konsole) :

      root@myhost:/usr/lib# cp -s /usr/local/lib/libcclc.a .
      root@myhost:/usr/lib# ll libccl*
      lrwxrwxrwx 1 root root 24 2007-10-10 13:47 libcclc.a -> /usr/local/lib/libcclc.a
      root@myhost:/usr/lib# cp -s /usr/local/lib/libcclc.la .
      root@myhost:/usr/lib# cp -s /usr/local/lib/libcclc.so .
      root@myhost:/usr/lib# cp -s /usr/local/lib/libcclc.so.0 .
      root@myhost:/usr/lib# cp -s /usr/local/lib/libcclc.so.0.7.1 .
      root@myhost:/usr/lib#
      root@myhost:/usr/lib#
      root@myhost:/usr/lib# cclcfox
      Usage: cclcfox -host <server> -name <myname> [options]

      <server>: the server's hostname or IP
      <myname>: the name this client is going to be identified with

      Options:
              -port <port>: Connect to the specified port (default: 2999).
              -nossl: do not use SSL to connect (default: use SSL).
              -certpass <password>: password used for the cerfificate (default: none).
                                    Ignored if not using SSL (-nossl option enabled).
      root@myhost:/usr/lib#

      How do I get it to run automatically? Perhaps only for a certain user ?
      rc.local ???? :)

      Right. Guess I'll try to install the server in an XP PC, now.
      Any pointers ?

      Thanks !